summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-07-20 23:09:07 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-07-20 23:09:51 +0700
commiteec1a5f924d47fb9a03ffc7d49c2b625ca9bd04e (patch)
tree2715921222adafa95344fdf78b3fef829f8a3f68 /app-text/pdfarranger/pdfarranger-1.10.0.ebuild
parentapp-emacs/magit: Suppress warning message about missing magit-libgit (diff)
downloadgentoo-eec1a5f924d47fb9a03ffc7d49c2b625ca9bd04e.tar.gz
gentoo-eec1a5f924d47fb9a03ffc7d49c2b625ca9bd04e.tar.bz2
gentoo-eec1a5f924d47fb9a03ffc7d49c2b625ca9bd04e.zip
app-text/pdfarranger: bump to 1.10.0
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text/pdfarranger/pdfarranger-1.10.0.ebuild')
-rw-r--r--app-text/pdfarranger/pdfarranger-1.10.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/pdfarranger/pdfarranger-1.10.0.ebuild b/app-text/pdfarranger/pdfarranger-1.10.0.ebuild
new file mode 100644
index 000000000000..44893f0ef11c
--- /dev/null
+++ b/app-text/pdfarranger/pdfarranger-1.10.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 optfeature xdg desktop
+
+DESCRIPTION="Merge or split pdfs; rearrange, rotate, crop pages"
+HOMEPAGE="https://github.com/jeromerobert/pdfarranger"
+SRC_URI="https://github.com/jeromerobert/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ app-text/poppler[introspection,cairo]
+ >=dev-python/pikepdf-6.0.0[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ dev-util/intltool
+"
+
+src_install() {
+ distutils-r1_src_install
+ for x in 16 32 48 256 scalable
+ do doicon -s ${x} data/icons/hicolor/${x}*/*
+ done
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "image file import" media-gfx/img2pdf
+}