summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-03-05 23:10:35 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-03-05 23:11:33 +0000
commit6b7cdc2cae8eecfffa10c1f501f415a3f469b27b (patch)
tree60ac6bb8bf89df450dc6a7cfe9120986c637c505 /app-text/pdfminer/pdfminer-20140328-r1.ebuild
parentsys-boot/grub: x86 stable wrt bug #575596 (diff)
downloadgentoo-6b7cdc2cae8eecfffa10c1f501f415a3f469b27b.tar.gz
gentoo-6b7cdc2cae8eecfffa10c1f501f415a3f469b27b.tar.bz2
gentoo-6b7cdc2cae8eecfffa10c1f501f415a3f469b27b.zip
app-text/pdfminer: Renable tests.
Tests do not fail anymore so renable them and fix a bug whilst at it. Gentoo-Bug: https://bugs.gentoo.org/439788 Package-Manager: portage-2.2.26 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-text/pdfminer/pdfminer-20140328-r1.ebuild')
-rw-r--r--app-text/pdfminer/pdfminer-20140328-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/pdfminer/pdfminer-20140328-r1.ebuild b/app-text/pdfminer/pdfminer-20140328-r1.ebuild
new file mode 100644
index 000000000000..9f0c142226e6
--- /dev/null
+++ b/app-text/pdfminer/pdfminer-20140328-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python tool for extracting information from PDF documents"
+HOMEPAGE="http://www.unixuser.org/~euske/python/pdfminer/ https://pypi.python.org/pypi/pdfminer/"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+python_compile_all(){
+ use examples && emake -C samples all
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ use examples && local EXAMPLES=( samples/. )
+ distutils-r1_python_install_all
+}