summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2019-10-25 19:24:46 +0100
committerJoonas Niilola <juippis@gentoo.org>2019-10-28 08:09:00 +0200
commit18616e8d63a70eebc4d70de710f362d696d6b0c6 (patch)
tree10a81d5e2e334418683a2b0d7ab328c1d64a4b9f /app-text/pdfminer/pdfminer-20191020.ebuild
parentnet-analyzer/metasploit: drop 'openvas' USE (diff)
downloadgentoo-18616e8d63a70eebc4d70de710f362d696d6b0c6.tar.gz
gentoo-18616e8d63a70eebc4d70de710f362d696d6b0c6.tar.bz2
gentoo-18616e8d63a70eebc4d70de710f362d696d6b0c6.zip
app-text/pdfminer: version bump to 20191020, Python 3 only
Bug: https://bugs.gentoo.org/623470 Package-Manager: Portage-2.3.77, Repoman-2.3.16 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/13402 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text/pdfminer/pdfminer-20191020.ebuild')
-rw-r--r--app-text/pdfminer/pdfminer-20191020.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/pdfminer/pdfminer-20191020.ebuild b/app-text/pdfminer/pdfminer-20191020.ebuild
new file mode 100644
index 000000000000..77050f5937cf
--- /dev/null
+++ b/app-text/pdfminer/pdfminer-20191020.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python tool for extracting information from PDF documents"
+HOMEPAGE="https://euske.github.io/pdfminer/ https://pypi.org/project/pdfminer/"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use examples && emake -C samples all
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ use examples && dodoc -r samples
+ distutils-r1_python_install_all
+}