summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/pdfsandwich
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/pdfsandwich')
-rw-r--r--app-text/pdfsandwich/Manifest1
-rw-r--r--app-text/pdfsandwich/metadata.xml25
-rw-r--r--app-text/pdfsandwich/pdfsandwich-0.1.4.ebuild41
3 files changed, 67 insertions, 0 deletions
diff --git a/app-text/pdfsandwich/Manifest b/app-text/pdfsandwich/Manifest
new file mode 100644
index 000000000000..67b94d72e7c0
--- /dev/null
+++ b/app-text/pdfsandwich/Manifest
@@ -0,0 +1 @@
+DIST pdfsandwich-0.1.4.tar.bz2 16401 SHA256 8b82f3ae08000c5cae1ff5a0f6537b0b563befef928e5198255b743a46714af3 SHA512 ee03aea13c72cc5a02136b5d16d2425f685f0b7a9d6fa6cff6c792bd24e6316720dff321b5e8237b949c98c713f39cb8b08b855b76e2a77350927b1ee7943171 WHIRLPOOL d8eb5fd281b1eb3f9e371ee71c486b8e839048f3ab569f8b62644e21ad921692283b2d35dfeb07111f86cf52eeb926da4152fcf58124cca2f96aa05116e8e115
diff --git a/app-text/pdfsandwich/metadata.xml b/app-text/pdfsandwich/metadata.xml
new file mode 100644
index 000000000000..6bfdb50e39db
--- /dev/null
+++ b/app-text/pdfsandwich/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tomka@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+pdfsandwich generates "sandwich" OCR pdf files, i.e. pdf files which
+contain only images (no text) will be processed by optical character
+recognition (OCR) and the text will be added to each page invisibly
+"behind" the images.
+
+pdfsandwich is a command line tool which is supposed to be useful to
+OCR scanned books or journals. It is able to recognize the page layout
+even for multicolumn text.
+
+Essentially, pdfsandwich is a wrapper script which calls the following
+binaries: convert, cuneiform, gs, and hocr2pdf. It is known to run on
+Unix systems and has been tested on Linux and MacOS X. It supports
+parallel processing on multiprocessor systems.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pdfsandwich</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/pdfsandwich/pdfsandwich-0.1.4.ebuild b/app-text/pdfsandwich/pdfsandwich-0.1.4.ebuild
new file mode 100644
index 000000000000..23bf7abd4bea
--- /dev/null
+++ b/app-text/pdfsandwich/pdfsandwich-0.1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="generator of sandwich OCR pdf files"
+HOMEPAGE="http://www.tobias-elze.de/pdfsandwich"
+SRC_URI="mirror://sourceforge/pdfsandwich/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="png"
+
+RDEPEND=">=app-text/tesseract-3.00
+ media-gfx/exact-image
+ app-text/unpaper
+ app-text/ghostscript-gpl
+ || (
+ media-gfx/imagemagick[png?]
+ media-gfx/graphicsmagick[png?]
+ )"
+DEPEND="sys-apps/gawk
+ >=dev-lang/ocaml-3.10[ocamlopt]"
+
+src_prepare() {
+ sed -i "/^OCAMLOPTFLAGS/s/$/ -ccopt \"\$(CFLAGS) \$(LDFLAGS)\"/" Makefile || die
+ sed -i "s/install -s/install/" Makefile || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ elog "pdfsandwich relies on the tesseract library for OCR."
+ elog "Consequently language support is determined by tesseract's"
+ elog "language support which in turn is controlled via the LINGUAS"
+ elog "variable in make.conf."
+}