summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/pdfshuffler
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/pdfshuffler')
-rw-r--r--app-text/pdfshuffler/Manifest1
-rw-r--r--app-text/pdfshuffler/files/pdfshuffler-PyPDF2.patch18
-rw-r--r--app-text/pdfshuffler/metadata.xml11
-rw-r--r--app-text/pdfshuffler/pdfshuffler-0.6.0-r1.ebuild40
-rw-r--r--app-text/pdfshuffler/pdfshuffler-0.6.0.ebuild46
5 files changed, 116 insertions, 0 deletions
diff --git a/app-text/pdfshuffler/Manifest b/app-text/pdfshuffler/Manifest
new file mode 100644
index 000000000000..06c1cb46d2b2
--- /dev/null
+++ b/app-text/pdfshuffler/Manifest
@@ -0,0 +1 @@
+DIST pdfshuffler-0.6.0.tar.gz 48071 SHA256 df3629b5a0ba91fda6b703ddf7b3e6f224a01d5cdfb76a5de77d67615466ef58 SHA512 e2563e9b5faf3ebac56f3840017ad9279a5e8e096c9f44ec053c617894910b1d0531457bc37d8fb9bc1db13ae25b94d55ca0b4ec26fbddeb9e51e6b4d75293fe WHIRLPOOL 72463cd666892af708208fd5816d882d956e3c068744e270775079107ea3b583cb81adc0225fc2e88232df3c74d292056804fff6bf64e707afe17359eaba21a4
diff --git a/app-text/pdfshuffler/files/pdfshuffler-PyPDF2.patch b/app-text/pdfshuffler/files/pdfshuffler-PyPDF2.patch
new file mode 100644
index 000000000000..8228c1765143
--- /dev/null
+++ b/app-text/pdfshuffler/files/pdfshuffler-PyPDF2.patch
@@ -0,0 +1,18 @@
+diff -r -U2 pdfshuffler-0.6.0.orig/pdfshuffler/pdfshuffler.py pdfshuffler-0.6.0/pdfshuffler/pdfshuffler.py
+--- pdfshuffler-0.6.0.orig/pdfshuffler/pdfshuffler.py 2012-04-28 21:15:17.000000000 +0700
++++ pdfshuffler-0.6.0/pdfshuffler/pdfshuffler.py 2015-01-11 02:10:02.952809411 +0600
+@@ -72,5 +72,13 @@
+
+ import poppler #for the rendering of pdf pages
+-from pyPdf import PdfFileWriter, PdfFileReader
++
++try:
++ from PyPDF2 import PdfFileWriter, PdfFileReader
++except ImportError:
++ try:
++ from pyPdf import PdfFileWriter, PdfFileReader
++ except ImportError:
++ print('Neither PyPDF2 nor pyPdf found')
++ sys.exit(1)
+
+ from pdfshuffler_iconview import CellRendererImage
diff --git a/app-text/pdfshuffler/metadata.xml b/app-text/pdfshuffler/metadata.xml
new file mode 100644
index 000000000000..da959993d99a
--- /dev/null
+++ b/app-text/pdfshuffler/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+</maintainer>
+<upstream>
+ <remote-id type="sourceforge">pdfshuffler</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-text/pdfshuffler/pdfshuffler-0.6.0-r1.ebuild b/app-text/pdfshuffler/pdfshuffler-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..c5cc668648f6
--- /dev/null
+++ b/app-text/pdfshuffler/pdfshuffler-0.6.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 fdo-mime gnome2-utils
+
+DESCRIPTION="GUI app that can merge or split pdfs and rotate, crop and rearrange their pages"
+HOMEPAGE="http://sourceforge.net/projects/pdfshuffler/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="|| ( dev-python/PyPDF2 dev-python/pyPdf )
+ dev-python/python-poppler"
+RDEPEND="${DEPEND}"
+
+DOCS="ChangeLog README TODO AUTHORS"
+PATCHES=( "${FILESDIR}"/${PN}-PyPDF2.patch )
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/app-text/pdfshuffler/pdfshuffler-0.6.0.ebuild b/app-text/pdfshuffler/pdfshuffler-0.6.0.ebuild
new file mode 100644
index 000000000000..28777dc16fba
--- /dev/null
+++ b/app-text/pdfshuffler/pdfshuffler-0.6.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit distutils eutils fdo-mime gnome2-utils
+
+DESCRIPTION="PDF-Shuffler is GUI app that can merge or split pdfs and rotate, crop and rearrange their pages"
+HOMEPAGE="http://sourceforge.net/projects/pdfshuffler/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/pyPdf
+ dev-python/python-poppler"
+RDEPEND="${DEPEND}"
+
+DOCS="ChangeLog README TODO AUTHORS"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}