summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-10 18:10:32 +0100
committerSam James <sam@gentoo.org>2022-04-10 18:13:06 +0100
commit0153750e42b8274f35fd4f5e5e7652e48eb27bfd (patch)
tree1e2d049a5cd146bbabf250940bff74e07eb22c62 /app-text/pelican
parentapp-containers/podman: drop vulnerable version (diff)
downloadgentoo-0153750e42b8274f35fd4f5e5e7652e48eb27bfd.tar.gz
gentoo-0153750e42b8274f35fd4f5e5e7652e48eb27bfd.tar.bz2
gentoo-0153750e42b8274f35fd4f5e5e7652e48eb27bfd.zip
app-text/pelican: add missing dependency; sync live; sort deps
Closes: https://bugs.gentoo.org/836401 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/pelican-4.7.2-r1.ebuild (renamed from app-text/pelican/pelican-4.7.2.ebuild)22
-rw-r--r--app-text/pelican/pelican-9999.ebuild25
2 files changed, 24 insertions, 23 deletions
diff --git a/app-text/pelican/pelican-4.7.2.ebuild b/app-text/pelican/pelican-4.7.2-r1.ebuild
index bc44f2e4f3c2..9c365026ac33 100644
--- a/app-text/pelican/pelican-4.7.2.ebuild
+++ b/app-text/pelican/pelican-4.7.2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+PYTHON_COMPAT=( python3_{8,9,10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -18,18 +18,18 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc examples markdown"
RESTRICT="test"
-RDEPEND=">=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
+RDEPEND=">=dev-python/docutils-0.16[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
+ >=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
>=dev-python/jinja-2.7[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/unidecode[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/six-1.4[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.6[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2020.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-10.1[${PYTHON_USEDEP}]
+ >=dev-python/unidecode-1.1[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )"
-DEPEND="test? ( dev-python/markdown[${PYTHON_USEDEP}] )"
+ markdown? ( >=dev-python/markdown-3.1[${PYTHON_USEDEP}] )"
+BDEPEND="test? ( >=dev-python/markdown-3.1[${PYTHON_USEDEP}] )"
DOCS=( README.rst )
diff --git a/app-text/pelican/pelican-9999.ebuild b/app-text/pelican/pelican-9999.ebuild
index ea34fe5b61b9..aa9807867aa1 100644
--- a/app-text/pelican/pelican-9999.ebuild
+++ b/app-text/pelican/pelican-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9,10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 git-r3
@@ -18,18 +18,19 @@ SLOT="0"
IUSE="doc examples markdown"
RESTRICT="test"
-RDEPEND=">=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
+RDEPEND=">=dev-python/docutils-0.16[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
+ >=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
>=dev-python/jinja-2.7[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/unidecode[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/six-1.4[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.6[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2020.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-10.1[${PYTHON_USEDEP}]
+ >=dev-python/unidecode-1.1[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )"
-DEPEND="test? ( dev-python/markdown[${PYTHON_USEDEP}] )"
+ markdown? ( >=dev-python/markdown-3.1[${PYTHON_USEDEP}] )"
+BDEPEND="test? ( >=dev-python/markdown-3.1[${PYTHON_USEDEP}] )"
+
DOCS=( README.rst )
distutils_enable_tests nose