summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-10-08 17:01:32 -0400
committerAaron Bauman <bman@gentoo.org>2019-10-08 17:01:32 -0400
commit204f1a517f46d69fc25ab15ab45d31d5975766f5 (patch)
tree2cfbd90e377ff8babf25b76b13f50df1c333ae30 /app-text/pelican
parentsys-apps/habitat: remove virtual/cargo dep (diff)
downloadgentoo-204f1a517f46d69fc25ab15ab45d31d5975766f5.tar.gz
gentoo-204f1a517f46d69fc25ab15ab45d31d5975766f5.tar.bz2
gentoo-204f1a517f46d69fc25ab15ab45d31d5975766f5.zip
app-text/pelican: non-maintainer bump to 4.1.2
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/Manifest1
-rw-r--r--app-text/pelican/pelican-4.1.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-text/pelican/Manifest b/app-text/pelican/Manifest
index ce3e37783912..c8b3af10c270 100644
--- a/app-text/pelican/Manifest
+++ b/app-text/pelican/Manifest
@@ -1,3 +1,4 @@
DIST pelican-3.7.1.tar.gz 784605 BLAKE2B 42adef016f54a931e4fef225af9a4c5c880b66c96660c2a34137a425f879688822ddc8bbc19805444bf2b49369c3dccf8a5303748ff9e7cbde3910d6ba501652 SHA512 9e04e6a2009cc134f74410d8c8349831467192e7524287e23cad0b68232f2b5dd04f5d98505222d71eb3441e466bccec1cafc7f6e3c6bfcb4c5e57e4ab0fadda
DIST pelican-4.0.0.tar.gz 1314626 BLAKE2B 18924209949b43063416f2e2c6e22a5524a36bab79a801f7cc6953c0822beb1bd5b05e715f5bcdb7c4877aba8d7a62cf4276e8abc43406f3c6fd7af8ef0c7c2f SHA512 5d98f5e13e6dde6b27cc299f9fb166edec79efb3fc53b29567218e0d0ba164989ce51830029ec8359697bc039661f6b0ced8d4155105e29098c038840c97d253
DIST pelican-4.0.1.tar.gz 1314716 BLAKE2B 1fbe01f5df7f1c730d7a45429369311f77c7e8e278a05cc037e03d8193dc2ae9075ee1346fea072a08ee5d73baf9aaed8c1f8f210fd4331754accca9ebffa4da SHA512 26f91046124bb92de6fa31d17ab89f743cf9408c15b9b259875e2378342133313368418da083d1d4abc5de0537806a9dede327719c8fcf89d135805c47618a4a
+DIST pelican-4.1.2.tar.gz 1329126 BLAKE2B ec6067b9df2bf37877ca23602228b2eff035221ef16ed1f185e2806fd661c8b733603506f3f1d9516422bd8009a0712f726d40559a39b0d100224ee56c3e706c SHA512 9a20e3a16e2caa15b6a47281d4acd6ada344292f011d4fd30c6ac786aebbccffd9cd0b2fd80471d3a383d4cb0ba779c51653705572760e62f6c2d3d49a862a67
diff --git a/app-text/pelican/pelican-4.1.2.ebuild b/app-text/pelican/pelican-4.1.2.ebuild
new file mode 100644
index 000000000000..c165da40c9a6
--- /dev/null
+++ b/app-text/pelican/pelican-4.1.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to generate a static blog, with restructured text or markdown input files"
+HOMEPAGE="https://blog.getpelican.com/ https://pypi.org/project/pelican/"
+SRC_URI="https://github.com/getpelican/pelican/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples markdown test"
+
+DEPEND=">=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+RESTRICT="test"
+
+DOCS=( README.rst )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ docompress -x "/usr/share/doc/${PF}/samples"
+ doins -r samples
+ fi
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}