summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2015-09-20 10:43:43 +0200
committerDirkjan Ochtman <djc@gentoo.org>2015-09-20 10:43:43 +0200
commit5b93b4517499ae57cb3ad30b69f6e73481a08af6 (patch)
tree6432ad530dd32574773f39d5ac3a30311f09ea45 /app-text/pelican
parentdev-python/ipython: Stable for PPC64 (bug #560708). (diff)
downloadgentoo-5b93b4517499ae57cb3ad30b69f6e73481a08af6.tar.gz
gentoo-5b93b4517499ae57cb3ad30b69f6e73481a08af6.tar.bz2
gentoo-5b93b4517499ae57cb3ad30b69f6e73481a08af6.zip
app-text/pelican: version bump to 3.6.3
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/Manifest1
-rw-r--r--app-text/pelican/pelican-3.6.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/pelican/Manifest b/app-text/pelican/Manifest
index 8828ebfa502a..6141db78eed7 100644
--- a/app-text/pelican/Manifest
+++ b/app-text/pelican/Manifest
@@ -1,3 +1,4 @@
DIST pelican-3.4.0.tar.gz 755768 SHA256 54f9b63f24db7db7cc2aae25b239707af3ec582fa585cf864d9f50dfd4ed1d93 SHA512 358563998eb1e333007f90f9d6f97ed842e42240966ab329dd08d1dcc2c70dd9793604745ed14369a1736a01268b55c101304ae265c6b5bf4179bb4363706a0b WHIRLPOOL 8e2f085fd956d4037372e30304874dea294b8237904ab44d0d70b01c1282f8849202790e194f3e2512af2460bc1da3a44146e50bd91cea20e0cbd804c74c43c9
DIST pelican-3.5.0.tar.gz 766994 SHA256 0a93e6c8cdccf5c6de61d96e5604185f71de3b29b313d0d378d188cb22821849 SHA512 fdb9fd202933dac29861e6bb9937aed13259c5808391499d9e43e619bfe89fcf10286f452f9c6d3beb7e3ee9de4c2c8b573a7f7a2d03e0159afe26f19a4b8396 WHIRLPOOL 2a6ca7b85c372cf37a98d3407b38cd5fd320053df32c7112c53ee3f336b69d3636b571a11e17afbe63e0d78398fc715f3009da04ef018be5f63c16ddf9af7ce6
DIST pelican-3.6.0.tar.gz 773887 SHA256 ff0db0e355295d1170988dc6d22388f3681f75accd51d02455638ad18a85c837 SHA512 7c4bcda6155b363d9e0d31d1763f20f9e3a3e9c5cd250ef4ce02305504e910c3ad61b3ae4ab909d1bca51a46102fe59583a6700f5a32a14d0c1cde47507db3d0 WHIRLPOOL 6685061f617f56b36cdb29f303765eace8703229caaae7d680b035a6a38ff7341bf72e06c8f980a8b28f156f429995e3e91c752337bd14fd9641813f63957131
+DIST pelican-3.6.3.tar.gz 775060 SHA256 d19bc7df61afc5b68eba028f0cf0832ee2a12a04a01d7fe11bdfdd847ddd417b SHA512 8bd8fcb72e67955d9c267731f74905417174d0767ec159d9b141e74aaa3cd8ee095270a7cc30847c413c702944df0c0b974ff8e98c55aa5004c00dbc55eadb16 WHIRLPOOL d4f021bba46dddb73159aa21d034b589978a823fed29ab07ad8aac1adf15b94f8f88a813253fedf9fb118e4e3e925bdc86487ddd6ba3427954ca1e184105b2cf
diff --git a/app-text/pelican/pelican-3.6.3.ebuild b/app-text/pelican/pelican-3.6.3.ebuild
new file mode 100644
index 000000000000..a16143d1e200
--- /dev/null
+++ b/app-text/pelican/pelican-3.6.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to generate a static blog, with restructured text (or markdown) input files"
+HOMEPAGE="http://pelican.notmyidea.org/ https://pypi.python.org/pypi/pelican"
+SRC_URI="https://github.com/getpelican/pelican/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples markdown"
+
+DEPEND=">=dev-python/feedgenerator-1.6[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS=( README.rst )
+
+python_install_all() {
+ use examples && local EXAMPLES=( samples/. )
+ distutils-r1_python_install_all
+}
+
+# no tests: tests/content not in tarball for 2.8.1
+# for 3.0, should be based on tox (refer to virtualenvwrapper)
+
+#python_test() {
+# esetup.py test
+#}