summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-13 10:14:42 +0000
committerSam James <sam@gentoo.org>2023-01-13 10:17:36 +0000
commit5f47ea50fe359ccb308e5cbce24750bc2315dc0c (patch)
tree3236f0166b498e4e628ca006e7ccf6a10461d033 /app-text/pelican
parentmedia-sound/beets: fix build w/ sphinx 6 (diff)
downloadgentoo-5f47ea50fe359ccb308e5cbce24750bc2315dc0c.tar.gz
gentoo-5f47ea50fe359ccb308e5cbce24750bc2315dc0c.tar.bz2
gentoo-5f47ea50fe359ccb308e5cbce24750bc2315dc0c.zip
app-text/pelican: fix build w/ sphinx 6
Closes: https://bugs.gentoo.org/889706 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/files/pelican-4.8.0-sphinx-6.patch20
-rw-r--r--app-text/pelican/pelican-4.8.0.ebuild6
2 files changed, 25 insertions, 1 deletions
diff --git a/app-text/pelican/files/pelican-4.8.0-sphinx-6.patch b/app-text/pelican/files/pelican-4.8.0-sphinx-6.patch
new file mode 100644
index 000000000000..60302f21a072
--- /dev/null
+++ b/app-text/pelican/files/pelican-4.8.0-sphinx-6.patch
@@ -0,0 +1,20 @@
+https://bugs.gentoo.org/889706
+https://github.com/getpelican/pelican/commit/33aca76d78601f0f0da635c8a14c89bbbc9ff8d6
+
+From 33aca76d78601f0f0da635c8a14c89bbbc9ff8d6 Mon Sep 17 00:00:00 2001
+From: Justin Mayer <entroP@gmail.com>
+Date: Mon, 1 Aug 2022 12:36:54 +0200
+Subject: [PATCH] Adjust extlinks configuration for Sphinx 5.0+
+
+--- a/docs/conf.py
++++ b/docs/conf.py
+@@ -23,7 +23,7 @@
+ '''.format(last_stable)
+
+ extlinks = {
+- 'pelican-doc': ('https://docs.getpelican.com/%s/', '')
++ 'pelican-doc': ('https://docs.getpelican.com/%s/', '%s')
+ }
+
+ # -- Options for HTML output --------------------------------------------------
+
diff --git a/app-text/pelican/pelican-4.8.0.ebuild b/app-text/pelican/pelican-4.8.0.ebuild
index 46e07a259b83..2b2b943036ec 100644
--- a/app-text/pelican/pelican-4.8.0.ebuild
+++ b/app-text/pelican/pelican-4.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -45,6 +45,10 @@ EPYTEST_DESELECT=(
pelican/tests/test_pelican.py::TestPelican::test_custom_generation_works
)
+PATCHES=(
+ "${FILESDIR}"/${P}-sphinx-6.patch
+)
+
distutils_enable_tests pytest
python_compile_all() {