summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-05-02 14:58:59 +0200
committerIan Delaney <idella4@gentoo.org>2016-05-03 11:41:44 +0800
commit71d3f5fd003758cf77e3f3e3845b9ecc947a670d (patch)
treead1b06c7133720d4ee250f4b2462646520cda2ed /app-text/pelican
parentapp-text/pelican: update HOMEPAGE and metadata.xml (diff)
downloadgentoo-71d3f5fd003758cf77e3f3e3845b9ecc947a670d.tar.gz
gentoo-71d3f5fd003758cf77e3f3e3845b9ecc947a670d.tar.bz2
gentoo-71d3f5fd003758cf77e3f3e3845b9ecc947a670d.zip
app-text/pelican: add support to py3.5
Add build / install of docs, uncomment & update test phase, bump EAPI to 6 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1393 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/pelican-3.6.3.ebuild35
1 files changed, 24 insertions, 11 deletions
diff --git a/app-text/pelican/pelican-3.6.3.ebuild b/app-text/pelican/pelican-3.6.3.ebuild
index d77fa3616071..e655459a7ba5 100644
--- a/app-text/pelican/pelican-3.6.3.ebuild
+++ b/app-text/pelican/pelican-3.6.3.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
inherit distutils-r1
@@ -14,7 +14,9 @@ SRC_URI="https://github.com/getpelican/pelican/archive/${PV}.tar.gz -> ${P}.tar.
LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="examples markdown"
+IUSE="doc examples markdown test"
+# Tests fail for this release but are fixed upstream
+RESTRICT="test"
DEPEND=">=dev-python/feedgenerator-1.6[${PYTHON_USEDEP}]
>=dev-python/jinja-2.7[${PYTHON_USEDEP}]
@@ -25,19 +27,30 @@ DEPEND=">=dev-python/feedgenerator-1.6[${PYTHON_USEDEP}]
dev-python/blinker[${PYTHON_USEDEP}]
>=dev-python/six-1.4[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
- markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )"
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ )"
RDEPEND=""
DOCS=( README.rst )
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
python_install_all() {
- use examples && local EXAMPLES=( samples/. )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ docompress -x "/usr/share/doc/${PF}/samples"
+ doins -r samples
+ fi
distutils-r1_python_install_all
}
-# no tests: tests/content not in tarball for 2.8.1
-# for 3.0, should be based on tox (refer to virtualenvwrapper)
-
-#python_test() {
-# esetup.py test
-#}
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}