summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-04 22:31:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-05 01:34:28 +0100
commita9865f4c3b45cd345fe630c20133bc9f1fc0f82d (patch)
tree95d03a5e454b15b6cd494363f5fb6393a74cf3f3 /app-text/poppler/poppler-9999.ebuild
parentprofiles: Mask unused KDE SC 4 remains for removal (diff)
downloadgentoo-a9865f4c3b45cd345fe630c20133bc9f1fc0f82d.tar.gz
gentoo-a9865f4c3b45cd345fe630c20133bc9f1fc0f82d.tar.bz2
gentoo-a9865f4c3b45cd345fe630c20133bc9f1fc0f82d.zip
app-text/poppler: Unconditionally build with -std=c++11
Closes: https://bugs.gentoo.org/643278 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-text/poppler/poppler-9999.ebuild')
-rw-r--r--app-text/poppler/poppler-9999.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index f84bcf398fb8..99060e661f22 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils toolchain-funcs xdg-utils
+inherit cmake-utils flag-o-matic toolchain-funcs xdg-utils
if [[ "${PV}" == "9999" ]] ; then
inherit git-r3
@@ -79,10 +79,8 @@ src_prepare() {
einfo "policy(SET CMP0002 OLD) - workaround can be removed"
fi
- if tc-is-clang && [[ ${CHOST} == *-darwin* ]] ; then
- # we need to up the C++ version, bug #622526
- export CXX="$(tc-getCXX) -std=c++11"
- fi
+ # we need to up the C++ version, bug #622526, #643278
+ append-cxxflags -std=c++11
}
src_configure() {