summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-03 23:13:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-03 23:24:59 +0100
commit230b9dfcb50ead207b963cb4df0a7ae46604b17c (patch)
tree73bf92e4486ea6106572db87775ef0c2388c6f66 /app-text/poppler
parentx11-misc/zim: drop 0.73.5, 0.74.0, 0.74.1, 0.74.2 (diff)
downloadgentoo-230b9dfcb50ead207b963cb4df0a7ae46604b17c.tar.gz
gentoo-230b9dfcb50ead207b963cb4df0a7ae46604b17c.tar.bz2
gentoo-230b9dfcb50ead207b963cb4df0a7ae46604b17c.zip
app-text/poppler: add 22.11.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/poppler')
-rw-r--r--app-text/poppler/Manifest2
-rw-r--r--app-text/poppler/poppler-22.11.0.ebuild134
2 files changed, 136 insertions, 0 deletions
diff --git a/app-text/poppler/Manifest b/app-text/poppler/Manifest
index 168feddf5e88..ab57e2b73ea8 100644
--- a/app-text/poppler/Manifest
+++ b/app-text/poppler/Manifest
@@ -2,3 +2,5 @@ DIST poppler-22.09.0.tar.xz 1842704 BLAKE2B 7104dc18582611901e55dbaa84d9ae871217
DIST poppler-22.09.0.tar.xz.sig 833 BLAKE2B bda372fa8d8d3d7ebe4263f9f81212d69e09b50e787a853390191c1bfcc38fd65f8e524f3810b6d3d25820ba5b2fe3d337c9e661c0747a73d64cbcdfb06b8205 SHA512 678e374c184e403b85cfbdc954b80fa4132f37d34eb60854f7708d7963b98f4e57997ec9a9aa8e17090ee696ff5821c3479857ef3f93a69e32c3f25744c84e43
DIST poppler-22.10.0.tar.xz 1844524 BLAKE2B 4784f0aa9bf19beb251e0b7e3a9f42d6e21fea6f9e2ccdffd5ffc59167902466faf4bc13ab20a4e30cb272010416ede61020ab781c601cbe808debcce93013ef SHA512 9f80a08ae7c6c41c2ae9a2f3d2fbd8b65e430f290d2603aaa6df39d1d69f4418f76584c3f20733fb38731e4a57a8b04f55cf0f9753dd8a43be7b6d18f609f116
DIST poppler-22.10.0.tar.xz.sig 833 BLAKE2B 0714d81b8ded72b239b7e8e8d7a7812336f03a2a37a242270b64c4622e994ad9f2798c49f8f8c2de9a0c3c732bd55a87ce37c66eb35819fa0a26ace072c0dc5a SHA512 6341fbbe65ae8ce132c7384f00ff4cef900854d72bfe2d1aae15767eef0a85e2817527ffea3e089dc08e076af4f72b67f1db559e90d32a9e29949b51abcf5a8d
+DIST poppler-22.11.0.tar.xz 1845444 BLAKE2B 958eb5e99725e46f3fd79138f4e1197ede9df5be19b6e5b0899b6a8c8b071734b3b41af7681bd857662e7d9c36fde09117418c1db347c5dad9a2fbd07cb1eec9 SHA512 a173681782b4f6c4528140ce73d1f4c0ca89a018eab7197d69f1a76ab3e6115c7c03f82e99a8b3e5729c0f75b82896e59b38762ed460dd29b704ab4a03926e7b
+DIST poppler-22.11.0.tar.xz.sig 833 BLAKE2B 8ebe07b5276272a29b9e7a427c066fb76a84c3ee1b7e259ddffe396c9c7798bb35092c2712e4d2d1f1ca6ec5226cf876717fb6858fe83cca1c39db25e231e1c9 SHA512 dabfbcb6bfde638fce6019a028e0d20951169a21751eb2474e67523800973a65dcb47855c8a908946026e3676cf0b1f782bcdd780fd5da0f035576df54610403
diff --git a/app-text/poppler/poppler-22.11.0.ebuild b/app-text/poppler/poppler-22.11.0.ebuild
new file mode 100644
index 000000000000..89fdf77aacf0
--- /dev/null
+++ b/app-text/poppler/poppler-22.11.0.ebuild
@@ -0,0 +1,134 @@
+# Copyright 2005-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs xdg-utils
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/poppler/poppler.git"
+ SLOT="0/9999"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/aacid.asc
+ inherit verify-sig
+
+ SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
+ SRC_URI+=" verify-sig? ( https://poppler.freedesktop.org/${P}.tar.xz.sig )"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SLOT="0/125" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+fi
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="https://poppler.freedesktop.org/"
+
+LICENSE="GPL-2"
+IUSE="boost cairo cjk curl +cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt5 tiff +utils"
+
+# No test data provided
+RESTRICT="test"
+
+COMMON_DEPEND="
+ media-libs/fontconfig
+ >=media-libs/freetype-2.8
+ sys-libs/zlib
+ cairo? (
+ dev-libs/glib:2
+ x11-libs/cairo
+ introspection? ( dev-libs/gobject-introspection:= )
+ )
+ curl? ( net-misc/curl )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ jpeg2k? ( >=media-libs/openjpeg-2.3.0-r1:2= )
+ lcms? ( media-libs/lcms:2 )
+ nss? ( >=dev-libs/nss-3.19:0 )
+ png? ( media-libs/libpng:0= )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtxml:5
+ )
+ tiff? ( media-libs/tiff:0 )
+"
+RDEPEND="${COMMON_DEPEND}
+ cjk? ( app-text/poppler-data )
+"
+DEPEND="${COMMON_DEPEND}
+ boost? ( dev-libs/boost )
+"
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+if [[ ${PV} != *9999* ]] ; then
+ BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-aacid )"
+fi
+
+DOCS=( AUTHORS NEWS README.md README-XPDF )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20.12.1-qt5-deps.patch"
+ "${FILESDIR}/${PN}-21.09.0-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.57.0-disable-internal-jpx.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Clang doesn't grok this flag, the configure nicely tests that, but
+ # cmake just uses it, so remove it if we use clang
+ if tc-is-clang ; then
+ sed -e 's/-fno-check-new//' -i cmake/modules/PopplerMacros.cmake || die
+ fi
+
+ if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then
+ sed -e '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \
+ -i CMakeLists.txt || die
+ else
+ einfo "policy(SET CMP0002 OLD) - workaround can be removed"
+ fi
+}
+
+src_configure() {
+ xdg_environment_reset
+ local mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT5_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DBUILD_MANUAL_TESTS=OFF
+ -DRUN_GPERF_IF_PRESENT=OFF
+ -DENABLE_BOOST="$(usex boost)"
+ -DENABLE_ZLIB=ON
+ -DENABLE_ZLIB_UNCOMPRESS=OFF
+ -DENABLE_UNSTABLE_API_ABI_HEADERS=ON
+ -DUSE_FLOAT=OFF
+ -DWITH_Cairo=$(usex cairo)
+ -DENABLE_LIBCURL=$(usex curl)
+ -DENABLE_CPP=$(usex cxx)
+ -DWITH_JPEG=$(usex jpeg)
+ -DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
+ -DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
+ -DENABLE_CMS=$(usex lcms lcms2 none)
+ -DWITH_NSS3=$(usex nss)
+ -DWITH_PNG=$(usex png)
+ $(cmake_use_find_package qt5 Qt5Core)
+ -DWITH_TIFF=$(usex tiff)
+ -DENABLE_UTILS=$(usex utils)
+ -DENABLE_QT6=OFF
+ )
+ use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # live version doesn't provide html documentation
+ if use cairo && use doc && [[ ${PV} != *9999* ]]; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/*
+ fi
+}