summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-08-09 21:53:49 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-08-09 21:54:09 +1000
commitbf741d439b77cc0e9bc908032ea764cafd5287b1 (patch)
tree00737ba99c3d268add7c0175e84c9b2cb66d63cc /app-text/poppler
parentprofiles/package.mask: update chromium mask for M62 (diff)
downloadgentoo-bf741d439b77cc0e9bc908032ea764cafd5287b1.tar.gz
gentoo-bf741d439b77cc0e9bc908032ea764cafd5287b1.tar.bz2
gentoo-bf741d439b77cc0e9bc908032ea764cafd5287b1.zip
app-text/poppler: sync live ebuild with release
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'app-text/poppler')
-rw-r--r--app-text/poppler/poppler-9999.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index 4f1e5562753b..b0c72bd971c3 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -12,16 +12,14 @@ if [[ "${PV}" == "9999" ]] ; then
else
SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- SLOT="0/67" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+ SLOT="0/68" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
fi
DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
HOMEPAGE="https://poppler.freedesktop.org/"
LICENSE="GPL-2"
-IUSE="cairo cairo-qt cjk curl cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt4 qt5 tiff +utils"
-
-REQUIRED_USE="cairo-qt? ( qt4 )"
+IUSE="cairo cjk curl cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt4 qt5 tiff +utils"
# No test data provided
RESTRICT="test"
@@ -84,6 +82,11 @@ src_prepare() {
else
einfo "policy(SET CMP0002 OLD) - workaround can be removed"
fi
+
+ if tc-is-clang && [[ ${CHOST} == *-darwin* ]] ; then
+ # we need to up the C++ version, bug #622526
+ export CXX="$(tc-getCXX) -std=c++11"
+ fi
}
src_configure() {
@@ -112,10 +115,15 @@ src_configure() {
$(cmake-utils_use_find_package qt5 Qt5Core)
-DWITH_TIFF="$(usex tiff)"
)
+ if use jpeg; then
+ mycmakeargs+=(-DENABLE_DCTDECODER=libjpeg)
+ else
+ mycmakeargs+=(-DENABLE_DCTDECODER=none)
+ fi
if use jpeg2k; then
mycmakeargs+=(-DENABLE_LIBOPENJPEG=openjpeg2)
else
- mycmakeargs+=(-DENABLE_LIBOPENJPEG=)
+ mycmakeargs+=(-DENABLE_LIBOPENJPEG=none)
fi
if use lcms; then
mycmakeargs+=(-DENABLE_CMS=lcms2)