summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/pspresent
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/pspresent')
-rw-r--r--app-text/pspresent/Manifest1
-rw-r--r--app-text/pspresent/metadata.xml7
-rw-r--r--app-text/pspresent/pspresent-1.3-r1.ebuild43
3 files changed, 51 insertions, 0 deletions
diff --git a/app-text/pspresent/Manifest b/app-text/pspresent/Manifest
new file mode 100644
index 000000000000..fb4d2505078f
--- /dev/null
+++ b/app-text/pspresent/Manifest
@@ -0,0 +1 @@
+DIST pspresent-1.3.tar.gz 14357 SHA256 94f2b6fa437929c9add2b8f4554a204d49132170c1d167c4389c7de26f5a6f80 SHA512 cfca0b4758d03051cea95d077a45239103f6fd24dada775c3b7fb0b7f78863f6628b530a21834546546dc935596b6d93dbe45048a661fcc41152a4b97b8f21f3 WHIRLPOOL 2704797e1ae5bf7c7876f7cb79be57ac430fe2dc7ea7b0297fe77381f073c406eddc3878da247da6811755a9058290bad70495f597aef77a93fc4de1aa0edc86
diff --git a/app-text/pspresent/metadata.xml b/app-text/pspresent/metadata.xml
new file mode 100644
index 000000000000..ff62877c67ae
--- /dev/null
+++ b/app-text/pspresent/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-text/pspresent/pspresent-1.3-r1.ebuild b/app-text/pspresent/pspresent-1.3-r1.ebuild
new file mode 100644
index 000000000000..80511bf7ea00
--- /dev/null
+++ b/app-text/pspresent/pspresent-1.3-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tool to display full-screen PostScript presentations"
+SRC_URI="http://www.cse.unsw.edu.au/~matthewc/pspresent/${P}.tar.gz"
+HOMEPAGE="http://www.cse.unsw.edu.au/~matthewc/pspresent/"
+SLOT="0"
+LICENSE="GPL-2"
+
+IUSE="xinerama"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )
+ app-text/ghostscript-gpl"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ xinerama? ( x11-proto/xineramaproto )
+ >=sys-apps/sed-4"
+
+src_prepare() {
+ if ! use xinerama ; then
+ sed -i -e "/^XINERAMA/s/^/#/g" Makefile || die "sed Makefile"
+ fi
+ sed -i Makefile \
+ -e 's|= -Wall -O2|+= -Wall|g' \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die
+}
+
+src_install() {
+ dobin pspresent
+ doman pspresent.1
+}