summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-15 19:53:34 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-15 20:01:22 -0400
commit53cdd593c90f8bab8c49877b6f687277860c64e1 (patch)
treeecd37c478f16800934835190cb0e9c23078cd25e /app-text/pytextile
parentapp-forensics/foremost: Remove old package with QA issue. (diff)
downloadgentoo-53cdd593c90f8bab8c49877b6f687277860c64e1.tar.gz
gentoo-53cdd593c90f8bab8c49877b6f687277860c64e1.tar.bz2
gentoo-53cdd593c90f8bab8c49877b6f687277860c64e1.zip
app-text/pytextile: bump to 3.0.3
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-text/pytextile')
-rw-r--r--app-text/pytextile/Manifest1
-rw-r--r--app-text/pytextile/pytextile-3.0.3.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-text/pytextile/Manifest b/app-text/pytextile/Manifest
index 84ad11ce3ff1..f70b76be1d6d 100644
--- a/app-text/pytextile/Manifest
+++ b/app-text/pytextile/Manifest
@@ -1,2 +1,3 @@
DIST pytextile-2.3.3.tar.gz 42277 BLAKE2B a6e6e1d96695f3ada03f5da9bd8bd19b99da345d83c62b1d4f2e765303dfbbbee072da4611f1b29b46d28ed334373c809117940ff0c1238dea3b12fb9076656c SHA512 980c872bfdc056753fa5b344cbc828dbdc9ddfc2656f3cfb5c15b3351cfd9e4016f57af14b60af2f2764e556865301d7923a8f0687c5857fc2201bf10f56ab60
+DIST pytextile-3.0.3.tar.gz 48560 BLAKE2B f8d3077e2b8e4de7157dcd9ed17f7889301946c2d3034dbbb0171b4930bd7268c65ce1f950552db2b783aa48acae639d5f4ccfcbca96807562b4a6377c3dd220 SHA512 142fe77c8858b0444428f9ca0f24d1a054a1566f85f00fd5cf860bb705a19666249cd03420d258d5acfc9f45052dd25e52767492a60a10d986d86b711b54612f
DIST textile-2.1.8.tar.gz 34002 BLAKE2B 0f4643da3cf47cd9b27e7b3237c6eac8b951caab9f6f36da929e159d582ae9e8ac04b835bd9006d7392ed935a875e169eef276caa52e25d618cdeafa27cef626 SHA512 b1675a131b482f4926efb45312b16c722ff158d9296704918b56316d470056f986ce18d495525a8e9f236bdd62e09ca6a17b443a7db8c8c36e5d05fcffce67da
diff --git a/app-text/pytextile/pytextile-3.0.3.ebuild b/app-text/pytextile/pytextile-3.0.3.ebuild
new file mode 100644
index 000000000000..ffe603741631
--- /dev/null
+++ b/app-text/pytextile/pytextile-3.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+MY_PN="python-textile"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python port of Textile, A humane web text generator"
+HOMEPAGE="https://github.com/textile/python-textile"
+SRC_URI="https://github.com/textile/python-textile/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ # remove useless --cov arg injection
+ rm pytest.ini || die
+ # remove useless pytest-runner dep
+ sed -e "s/pytest-runner//g" -i setup.py || die
+}
+
+python_test() {
+ pytest || die "Testsuite failed under ${EPYTHON}"
+}