summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-03-04 09:16:59 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2016-03-04 12:17:04 -0800
commita8ad7d82931934e4531d762b4f5e033065965f8e (patch)
tree7100a282a40aceeed794dc0d5ddd42fc5ca9bc39 /app-text/q-text-as-data/q-text-as-data-1.5.0.ebuild
parentnet-im/skypetab-ng: pushed new snapshot, 0.5.2_p20150201 (diff)
downloadgentoo-a8ad7d82931934e4531d762b4f5e033065965f8e.tar.gz
gentoo-a8ad7d82931934e4531d762b4f5e033065965f8e.tar.bz2
gentoo-a8ad7d82931934e4531d762b4f5e033065965f8e.zip
app-text/q-text-as-data: new package.
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-text/q-text-as-data/q-text-as-data-1.5.0.ebuild')
-rw-r--r--app-text/q-text-as-data/q-text-as-data-1.5.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/q-text-as-data/q-text-as-data-1.5.0.ebuild b/app-text/q-text-as-data/q-text-as-data-1.5.0.ebuild
new file mode 100644
index 000000000000..aa6fcbb4de0f
--- /dev/null
+++ b/app-text/q-text-as-data/q-text-as-data-1.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+# Does not yet support py3
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="q: Text as Data is a CLI tool that allows direct execution of SQL-like queries on text"
+HOMEPAGE="http://harelba.github.io/q/"
+MY_P="q-${PV}"
+SRC_URI="https://github.com/harelba/q/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# No dependencies other than python >= 2.5
+# http://harelba.github.io/q/requirements.html
+RDEPEND="${PYTHON_DEPS}"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+q_install() {
+ python_newexe bin/q q-text-as-data
+}
+
+src_install() {
+ python_foreach_impl q_install
+ newdoc bin/.qrc dot-qrc
+ dodoc doc/*
+}
+
+pkg_postinst() {
+ einfo "On Gentoo, the 'q' binary is most often provided by app-portage/portage-utils;"
+ einfo "Thus, this tool is install as 'q-text-as-data' rather than 'q'."
+}