summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-12-24 16:15:43 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-12-24 16:15:43 +0100
commit71d7746088c2984b1c679dc3ee936fe83139f5d2 (patch)
treeaece4ce1b1fffd49c43bbb94b54367a1c588a50e /app-text/qpdf/qpdf-6.0.0.ebuild
parentapp-text/qpdf: Version bump (diff)
downloadgentoo-71d7746088c2984b1c679dc3ee936fe83139f5d2.tar.gz
gentoo-71d7746088c2984b1c679dc3ee936fe83139f5d2.tar.bz2
gentoo-71d7746088c2984b1c679dc3ee936fe83139f5d2.zip
app-text/qpdf: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-text/qpdf/qpdf-6.0.0.ebuild')
-rw-r--r--app-text/qpdf/qpdf-6.0.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-text/qpdf/qpdf-6.0.0.ebuild b/app-text/qpdf/qpdf-6.0.0.ebuild
new file mode 100644
index 000000000000..b31f1b04b5af
--- /dev/null
+++ b/app-text/qpdf/qpdf-6.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0/17" # subslot = libqpdf soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~m68k-mint ~sparc-solaris"
+IUSE="doc examples static-libs test"
+
+RDEPEND="dev-libs/libpcre
+ sys-libs/zlib
+ >=dev-lang/perl-5.8"
+DEPEND="${RDEPEND}
+ test? (
+ sys-apps/diffutils
+ media-libs/tiff
+ app-text/ghostscript-gpl
+ )"
+
+DOCS=( ChangeLog README TODO )
+
+src_prepare() {
+ # manually install docs
+ sed -i "/docdir/d" make/libtool.mk || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable test test-compare-images)
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ dodoc doc/qpdf-manual.pdf
+ dohtml doc/*
+ fi
+
+ if use examples ; then
+ dobin examples/build/.libs/*
+ fi
+
+ prune_libtool_files
+}