summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/qpdf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/qpdf')
-rw-r--r--app-text/qpdf/Manifest2
-rw-r--r--app-text/qpdf/metadata.xml8
-rw-r--r--app-text/qpdf/qpdf-5.1.1.ebuild54
-rw-r--r--app-text/qpdf/qpdf-5.1.2.ebuild54
4 files changed, 118 insertions, 0 deletions
diff --git a/app-text/qpdf/Manifest b/app-text/qpdf/Manifest
new file mode 100644
index 000000000000..609085aed236
--- /dev/null
+++ b/app-text/qpdf/Manifest
@@ -0,0 +1,2 @@
+DIST qpdf-5.1.1.tar.gz 7662701 SHA256 95d355d8fa5e1c677e04d884161de94f5438bf3bdc1638498796b042bad4a726 SHA512 236132290694730d7de08635560435d34ae44f4edbc1b887e494f2ee183271331827226e7e29e539d25d5a2ca1dd5815a387c46edc0b6fd898436bbb674d9993 WHIRLPOOL 66eee10dc5163f1e53afcbd02b71bab73598c28ebb9b005c26af4e58396fd693af7ed76a17fd0c29819b0fa08a71ea0158c76bfa0b0d452a78bb357277644459
+DIST qpdf-5.1.2.tar.gz 7664268 SHA256 e9dd8d5d0a322078ffd573f057f03d24a734cc5b7dd925b089ebcb0f6e867bfd SHA512 be2fe3f1127532edc1b3d9af2d25df64c2c04c402cfef8d1ca5ed77129c2f17ef3435abb6c630b260ee4be8458984c0fbf0abfb6cda82ef4fa74dc23ca7a8864 WHIRLPOOL 5ec875f0ea73aa044c671f4ea9e5b69c74c188463ad58006a55ed395fed4e0184baad760486596586866b9f701ae5e211ac08ade1eff54028e20c6c1462ee629
diff --git a/app-text/qpdf/metadata.xml b/app-text/qpdf/metadata.xml
new file mode 100644
index 000000000000..7db5520ddbda
--- /dev/null
+++ b/app-text/qpdf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>printing</herd>
+ <upstream>
+ <remote-id type="sourceforge">qpdf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/qpdf/qpdf-5.1.1.ebuild b/app-text/qpdf/qpdf-5.1.1.ebuild
new file mode 100644
index 000000000000..bcd0f7f4745b
--- /dev/null
+++ b/app-text/qpdf/qpdf-5.1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A command-line program that does structural, content-preserving transformations on PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0/13" # subslot = libqpdf soname version
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~m68k-mint ~sparc-solaris"
+IUSE="doc examples static-libs test"
+
+RDEPEND="dev-libs/libpcre
+ sys-libs/zlib
+ >=dev-lang/perl-5.8"
+DEPEND="${RDEPEND}
+ test? (
+ sys-apps/diffutils
+ media-libs/tiff
+ app-text/ghostscript-gpl
+ )"
+
+DOCS=( ChangeLog README TODO )
+
+src_prepare() {
+ # manually install docs
+ sed -i "/docdir/d" make/libtool.mk || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable test test-compare-images)
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ dodoc doc/qpdf-manual.pdf
+ dohtml doc/*
+ fi
+
+ if use examples ; then
+ dobin examples/build/.libs/*
+ fi
+
+ prune_libtool_files
+}
diff --git a/app-text/qpdf/qpdf-5.1.2.ebuild b/app-text/qpdf/qpdf-5.1.2.ebuild
new file mode 100644
index 000000000000..67e53490cb7d
--- /dev/null
+++ b/app-text/qpdf/qpdf-5.1.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A command-line program that does structural, content-preserving transformations on PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0/13" # subslot = libqpdf soname version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~m68k-mint ~sparc-solaris"
+IUSE="doc examples static-libs test"
+
+RDEPEND="dev-libs/libpcre
+ sys-libs/zlib
+ >=dev-lang/perl-5.8"
+DEPEND="${RDEPEND}
+ test? (
+ sys-apps/diffutils
+ media-libs/tiff
+ app-text/ghostscript-gpl
+ )"
+
+DOCS=( ChangeLog README TODO )
+
+src_prepare() {
+ # manually install docs
+ sed -i "/docdir/d" make/libtool.mk || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable test test-compare-images)
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ dodoc doc/qpdf-manual.pdf
+ dohtml doc/*
+ fi
+
+ if use examples ; then
+ dobin examples/build/.libs/*
+ fi
+
+ prune_libtool_files
+}