summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-24 14:51:17 +0000
committerSam James <sam@gentoo.org>2021-02-24 16:21:42 +0000
commita01f35055373a55b4055fbad514c84b54a4944ec (patch)
tree64dce4dcb35ff8d3402f5006721510d1309c83f8 /app-text/qpdf
parentapp-text/qpdf: add github remote-id (diff)
downloadgentoo-a01f35055373a55b4055fbad514c84b54a4944ec.tar.gz
gentoo-a01f35055373a55b4055fbad514c84b54a4944ec.tar.bz2
gentoo-a01f35055373a55b4055fbad514c84b54a4944ec.zip
app-text/qpdf: bump to 10.2.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/qpdf')
-rw-r--r--app-text/qpdf/Manifest1
-rw-r--r--app-text/qpdf/qpdf-10.2.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-text/qpdf/Manifest b/app-text/qpdf/Manifest
index 1cf9e94f082f..1b0fea927805 100644
--- a/app-text/qpdf/Manifest
+++ b/app-text/qpdf/Manifest
@@ -1,2 +1,3 @@
DIST qpdf-10.0.4.tar.gz 18465085 BLAKE2B 3b9edc38069d58d43d26b131da755b7921b7add905ed652e3abb48d9b2e140d0c3b38f0250dbd3dca1c4b3dadf76c636606c6fa802b1ebe2dda77444badd828e SHA512 0a8c243928a3273d78b4a898e17a619f1565ec5e9b6f637800a2937749fb8006d0438fee2e623d2f8dc715bfb478ee818e86e9da7c7e0fcf14af496464b79a07
DIST qpdf-10.1.0.tar.gz 18528427 BLAKE2B e62b1c8ca8d301b082cde292cb8430d6ae26433c77a30a6a21379f00cbfb3df09117d042f532f77d372d091a89a3f6581ef7d7734c67a4a1b29c1708129078f3 SHA512 f9b22d89fc62e430e6232c840ad74d220ac9eb09d7f2dfe2c42c1c943d35b5fd25e2abec9970ac19ad7ad25dc3d95c74e68e50bad395abf815cf71c432233106
+DIST qpdf-10.2.0.tar.gz 18816798 BLAKE2B 2983dd4ab8d234d6acb838abb57cd8e75edc540804608c3c3d387ee4c2f8ca8060b77e1b6f1a0950640835065fc681d9ad1dec5d8cf2a706727e237b71eabf8d SHA512 07a37aafccb670034aedfc031a4c2c1d3b6aa001e5c1bde5a3f57520a0523eebd890011a8225bb26b5beb83be15d4be3d2f1f40ad91f8370032db984cf788c0a
diff --git a/app-text/qpdf/qpdf-10.2.0.ebuild b/app-text/qpdf/qpdf-10.2.0.ebuild
new file mode 100644
index 000000000000..fa194fe13674
--- /dev/null
+++ b/app-text/qpdf/qpdf-10.2.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 Artistic-2 )"
+# subslot = libqpdf soname version
+SLOT="0/28"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris"
+IUSE="doc examples libressl ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ net-libs/gnutls:0=
+ sys-libs/zlib
+ virtual/jpeg:0=
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+DEPEND="${RDEPEND}
+ test? (
+ app-text/ghostscript-gpl[tiff(+)]
+ media-libs/tiff
+ sys-apps/diffutils
+ )
+"
+
+DOCS=( ChangeLog README.md TODO )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-implicit-crypto
+ --enable-crypto-gnutls
+ --enable-crypto-native
+ --with-default-crypto=gnutls
+ --disable-static
+ $(use_enable ssl crypto-openssl)
+ $(use_enable test test-compare-images)
+ )
+ CONFIG_SHELL="${BROOT}/bin/bash" econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ dobin examples/build/.libs/*
+ fi
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}