summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/rarian
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/rarian')
-rw-r--r--app-text/rarian/Manifest1
-rw-r--r--app-text/rarian/files/rarian-0.8.1-fix-old-doc.patch13
-rw-r--r--app-text/rarian/metadata.xml5
-rw-r--r--app-text/rarian/rarian-0.8.1-r2.ebuild51
4 files changed, 70 insertions, 0 deletions
diff --git a/app-text/rarian/Manifest b/app-text/rarian/Manifest
new file mode 100644
index 000000000000..b54bb63b7cda
--- /dev/null
+++ b/app-text/rarian/Manifest
@@ -0,0 +1 @@
+DIST rarian-0.8.1.tar.gz 459461 SHA256 b410d9581dddfabe93e29f9e235a9f9d04d33d8eb12afd0f5ad3bd238c55adef SHA512 ddc640e1ac210e9dc3fcdde6bbff6e21dabe97b160b531cac68d47d1b831dec71b7c4aced9819cfafd8f89f290920c4e33550b8e29d9872a1c1a202d6fe8e3eb WHIRLPOOL bd11206a4701e1771ebd5d82123d299c1c3cbb7ecfa6e00654372494d07b8f47cdfc6e88dc8ea6a405acdae0f57b12ae8c927a952f42d55cdab8f1214f0ac237
diff --git a/app-text/rarian/files/rarian-0.8.1-fix-old-doc.patch b/app-text/rarian/files/rarian-0.8.1-fix-old-doc.patch
new file mode 100644
index 000000000000..f84f987d8f10
--- /dev/null
+++ b/app-text/rarian/files/rarian-0.8.1-fix-old-doc.patch
@@ -0,0 +1,13 @@
+--- util/rarian-sk-preinstall.cpp.old 2008-09-01 20:40:21.000000000 +0200
++++ util/rarian-sk-preinstall.cpp 2010-01-30 11:29:39.000000000 +0100
+@@ -96,8 +96,8 @@
+ }
+ if (i == 1) {
+ /* Normal path. Add file:/ to the start */
+- new_url = (char *) malloc (sizeof(char) * (strlen (input) + 7));
+- sprintf (new_url, "file:/%s", input);
++ new_url = (char *) malloc (sizeof(char) * (strlen (input) + 8));
++ sprintf (new_url, "file://%s", input);
+ } else {
+ /* Don't know what to do. Just copy and append file: to it */
+ new_url = (char *) malloc (sizeof(char) * (strlen(input) + 6));
diff --git a/app-text/rarian/metadata.xml b/app-text/rarian/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/app-text/rarian/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>
diff --git a/app-text/rarian/rarian-0.8.1-r2.ebuild b/app-text/rarian/rarian-0.8.1-r2.ebuild
new file mode 100644
index 000000000000..7e3b48ca347d
--- /dev/null
+++ b/app-text/rarian/rarian-0.8.1-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils libtool
+
+DESCRIPTION="A documentation metadata library"
+HOMEPAGE="http://rarian.freedesktop.org/"
+SRC_URI="http://${PN}.freedesktop.org/Releases/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/libxslt
+ || ( sys-apps/util-linux app-misc/getopt )"
+DEPEND="${RDEPEND}
+ !<app-text/scrollkeeper-9999"
+
+DOCS=( ChangeLog NEWS README )
+
+src_prepare() {
+ # Fix uri of omf files produced by rarian-sk-preinstall, see bug #302900
+ epatch "${FILESDIR}/${P}-fix-old-doc.patch"
+
+ # remove unneeded line, bug #240564
+ sed "s/ (foreign dist-bzip2 dist-gzip)//" -i configure || die "sed failed"
+
+ # bug #409811, https://bugs.freedesktop.org/show_bug.cgi?id=53264
+ # sed to avoid autoreconf
+ if ! has_version sys-apps/util-linux; then
+ sed -e 's/getopt -/getopt-long -/' \
+ -i util/rarian-sk-update.in || die "sed 2 failed"
+ fi
+
+ elibtoolize ${ELTCONF}
+}
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}"/var \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}