summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-27 17:58:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-27 17:58:38 +0200
commitda0c580bad3991c3f96cc75ac755002e5b228201 (patch)
treeca162c2dc1c9b4fea26e2e3decb75e2af7d9da30 /app-text/teckit
parentdev-cpp/catch: Bump to 1.5.7 (diff)
downloadgentoo-da0c580bad3991c3f96cc75ac755002e5b228201.tar.gz
gentoo-da0c580bad3991c3f96cc75ac755002e5b228201.tar.bz2
gentoo-da0c580bad3991c3f96cc75ac755002e5b228201.zip
app-text/teckit: bump to 2.5.6
Package-Manager: portage-2.3.1
Diffstat (limited to 'app-text/teckit')
-rw-r--r--app-text/teckit/Manifest1
-rw-r--r--app-text/teckit/teckit-2.5.6.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-text/teckit/Manifest b/app-text/teckit/Manifest
index ac2e338ed710..20dfcd4a656f 100644
--- a/app-text/teckit/Manifest
+++ b/app-text/teckit/Manifest
@@ -1,2 +1,3 @@
DIST TECkit_2.5.3.tar.gz 2417611 SHA256 c048f1bdcfe3d361574818ca693e15295ece124f66db651f96c50379ae353e0c SHA512 7d2d315a38fa8df82a6180bfcd4737f5b9c664ff27d723c9dfd51902e0aa195d1eba4b49665cd22a2bbf28a9626b3569cb8aceb74b6f390c12c108a748a2e49e WHIRLPOOL 72046c709c1a2a12c52511669c4d0a3bca3800086041fa3cc15fb9d35274ea670bc4f1de19c574982fcea4aeff1824863dd57d96de010b36ca4d80fed8a599cc
DIST TECkit_2_5_1.tar.gz 2630207 SHA256 59a01952684c4599a7f30b4f0deedcb6276f04fce73ac6fcbcbd55c4e2e6513a SHA512 db38ead681a5f3005769bf86bd39e3e769836885f672aea593284f0ad90932827697c30244944097ac4173633e6d0daa86e993136f179c4634440384811b418c WHIRLPOOL 2967688f1d78b3c1f2c42a72c12bf7c8c612d182a232432d2083e4e1b05d2bd92115fe28e8bc29596414c7e81da7fc48277666141e39f217d7cb9ea09a46c5c2
+DIST teckit-2.5.6.tar.gz 2500800 SHA256 a27bcee822111efe56ee0c9047d6ed5d8cb1b5005c372517c42c4a7552884105 SHA512 d3462dbf22658de85fd718c43229259c460730d907226435195742f1ab65accc4ec83f7b6cb32a0e99fa12ddb7f2b7b5f2598c8853636aa5b31c8592ed9b4745 WHIRLPOOL 796d19d557e94871017b41978ebbecdb5f80cd6cafc15a6a395c56db76709c6bb64ee6536cf0ce29cda29bb92050faa765e437de9d362106d312ed66dfb7b1c6
diff --git a/app-text/teckit/teckit-2.5.6.ebuild b/app-text/teckit/teckit-2.5.6.ebuild
new file mode 100644
index 000000000000..837a4b59979d
--- /dev/null
+++ b/app-text/teckit/teckit-2.5.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Text Encoding Conversion toolkit"
+HOMEPAGE="http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&cat_id=TECkit"
+SRC_URI="https://github.com/silnrsi/teckit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( CPL-0.5 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/zlib
+ dev-libs/expat"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.5.1-mixcflagscxxflags.patch"
+ rm -f configure
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README NEWS
+}
+
+src_test() {
+ cd "${S}/test"
+ chmod +x dotests.pl
+ ./dotests.pl || die "tests failed"
+}