summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2018-03-06 11:06:19 +0100
committerGuilherme Amadio <amadio@gentoo.org>2018-03-06 15:43:01 +0100
commit30d023ace822899963eef7f451250ed45d99fbc7 (patch)
tree23837cc871e0892a91860755df320da2f30e1e47 /app-text/texi2html/texi2html-5.0-r1.ebuild
parentpackage.mask: Masked =net-misc/x2goserver-4.1.0.0-r1 (diff)
downloadgentoo-30d023ace822899963eef7f451250ed45d99fbc7.tar.gz
gentoo-30d023ace822899963eef7f451250ed45d99fbc7.tar.bz2
gentoo-30d023ace822899963eef7f451250ed45d99fbc7.zip
app-text/texi2html: prefix support
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-text/texi2html/texi2html-5.0-r1.ebuild')
-rw-r--r--app-text/texi2html/texi2html-5.0-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-text/texi2html/texi2html-5.0-r1.ebuild b/app-text/texi2html/texi2html-5.0-r1.ebuild
index f7e01f45b706..3c4b85e12fc2 100644
--- a/app-text/texi2html/texi2html-5.0-r1.ebuild
+++ b/app-text/texi2html/texi2html-5.0-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
+inherit prefix
+
DESCRIPTION="Perl script that converts Texinfo to HTML"
HOMEPAGE="http://www.nongnu.org/texi2html/"
SRC_URI="mirror://nongnu/${PN}/${P}.tar.bz2"
@@ -28,6 +30,10 @@ src_prepare() {
# On FreeBSD this script is used instead of GNU install but it comes without
# executable pemissions... Fix it!
chmod +x install-sh || die
+
+ if use prefix; then
+ hprefixify $(find . -name '*.pl' | xargs)
+ fi
}
src_configure() {