summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-12-10 17:39:14 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-10 17:45:03 +0100
commit9193b2bbb15ff0e2ae44f77f87f40de1bb8952f0 (patch)
tree99b7a789c6972a7159e096ceb36fadcc229d944c /app-text/tofrodos
parentnet-libs/daq: bump to v2.0.6 (diff)
downloadgentoo-9193b2bbb15ff0e2ae44f77f87f40de1bb8952f0.tar.gz
gentoo-9193b2bbb15ff0e2ae44f77f87f40de1bb8952f0.tar.bz2
gentoo-9193b2bbb15ff0e2ae44f77f87f40de1bb8952f0.zip
app-text/tofrodos: bump to v1.7.13
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-text/tofrodos')
-rw-r--r--app-text/tofrodos/Manifest1
-rw-r--r--app-text/tofrodos/files/tofrodos-1.7.13-CFLAGS.patch13
-rw-r--r--app-text/tofrodos/tofrodos-1.7.13.ebuild33
3 files changed, 47 insertions, 0 deletions
diff --git a/app-text/tofrodos/Manifest b/app-text/tofrodos/Manifest
index 8c602e9d6ec8..36d611cc515a 100644
--- a/app-text/tofrodos/Manifest
+++ b/app-text/tofrodos/Manifest
@@ -1 +1,2 @@
DIST tofrodos-1.7.12a.tar.gz 97588 BLAKE2B ca8794df5b58e0e88d23a52287ec3f9c58918baa6590b6e2d571782c4c2ff1625e208648cce8346b2f63b52031da5dd3aff0e66522e670525cdc09bdfd8744b0 SHA512 45a03203ccd053ec02a420fe4a63b427ee74dfa2c30e914836621a1cd7836ce81800e8bd5f1cccdb93233780ce79bc74d4ad49dca6192899b3039cf559baa8a2
+DIST tofrodos-1.7.13.tar.gz 99975 BLAKE2B 677b5cf7b1ef061b86a60229e083dc19ddcb7887b1319685ccd5a50493c1f02feb8556db3c2866f3ca1851304d0e97592a8abdd880a5f4e70eb7032f4238445d SHA512 629804caf20ac7bfc6f47637b7bc575766f032e324142df3be14347f050c61d969e023f8fed0ce5c87d8fc57b25c60c4e0214600738c5079d5e731045dae4843
diff --git a/app-text/tofrodos/files/tofrodos-1.7.13-CFLAGS.patch b/app-text/tofrodos/files/tofrodos-1.7.13-CFLAGS.patch
new file mode 100644
index 000000000000..dafdf66838ed
--- /dev/null
+++ b/app-text/tofrodos/files/tofrodos-1.7.13-CFLAGS.patch
@@ -0,0 +1,13 @@
+--- a/Makefile
++++ b/Makefile
+@@ -56,10 +56,6 @@ OBJS = emsg.o \
+ tofrodos.o \
+ utility.o
+
+-# implicit rules
+-.c.o:
+- $(CC) $(CFLAGS) $<
+-
+ # user visible rules
+ all: $(FROMDOS) $(TODOS)
+
diff --git a/app-text/tofrodos/tofrodos-1.7.13.ebuild b/app-text/tofrodos/tofrodos-1.7.13.ebuild
new file mode 100644
index 000000000000..23f51043153c
--- /dev/null
+++ b/app-text/tofrodos/tofrodos-1.7.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility that converts ASCII files between the MSDOS and the Unix format"
+HOMEPAGE="http://tofrodos.sourceforge.net/"
+SRC_URI="http://tofrodos.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}/src"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.7.13-CFLAGS.patch )
+
+src_compile() {
+ emake DEBUG=1 CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin fromdos
+ dosym fromdos /usr/bin/todos
+ doman fromdos.1
+}