summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2017-11-20 21:14:55 +0100
committerJonas Stein <jstein@gentoo.org>2017-11-20 21:36:41 +0100
commit2670946f0c4bb8904286a9215cc40011ab758bac (patch)
treef3a2bf6625d7589b8a043bdae09235cd76b7c871 /app-text/tree/tree-1.7.0-r1.ebuild
parentmedia-libs/adplug: Sync live ebuild (diff)
downloadgentoo-2670946f0c4bb8904286a9215cc40011ab758bac.tar.gz
gentoo-2670946f0c4bb8904286a9215cc40011ab758bac.tar.bz2
gentoo-2670946f0c4bb8904286a9215cc40011ab758bac.zip
app-text/tree: Bump to EAPI=6
EAPI bump and cleanup Package-Manager: Portage-2.3.14, Repoman-2.3.5
Diffstat (limited to 'app-text/tree/tree-1.7.0-r1.ebuild')
-rw-r--r--app-text/tree/tree-1.7.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/tree/tree-1.7.0-r1.ebuild b/app-text/tree/tree-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..254228739351
--- /dev/null
+++ b/app-text/tree/tree-1.7.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs flag-o-matic bash-completion-r1
+
+DESCRIPTION="Lists directories recursively, and produces an indented listing of files"
+HOMEPAGE="http://mama.indstate.edu/users/ice/tree/"
+SRC_URI="ftp://mama.indstate.edu/linux/tree/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="!=sci-biology/meme-4.8.1"
+DEPEND=""
+
+src_prepare() {
+ sed -i -e 's:LINUX:__linux__:' tree.c || die
+ mv doc/tree.1.fr doc/tree.fr.1
+ if use !elibc_glibc ; then
+ # 433972, also previously done only for elibc_uclibc
+ sed -i -e '/^OBJS=/s/$/ strverscmp.o/' Makefile || die
+ fi
+ default
+}
+
+src_compile() {
+ append-lfs-flags
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin tree
+ doman doc/tree*.1
+ einstalldocs
+ newbashcomp "${FILESDIR}"/${PN}.bashcomp ${PN}
+}