summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-05-01 18:05:43 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-05-18 13:33:25 +0300
commit352af12a667285b8127b77fc2d39b820230da8e4 (patch)
tree68f7932e0674dcd731fbd4f858a0e0bb2d36ad58 /app-text/uudeview
parentapp-text/uudeview: Replace hardcoded ar with `tc-getAR`. (diff)
downloadgentoo-352af12a667285b8127b77fc2d39b820230da8e4.tar.gz
gentoo-352af12a667285b8127b77fc2d39b820230da8e4.tar.bz2
gentoo-352af12a667285b8127b77fc2d39b820230da8e4.zip
app-text/uudeview: Make append_signature() void.
It seems that the function is never called. Closes: https://bugs.gentoo.org/735682 Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Closes: https://github.com/gentoo/gentoo/pull/20630 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text/uudeview')
-rw-r--r--app-text/uudeview/files/uudeview-0.5.20-fix-append_signature.patch36
-rw-r--r--app-text/uudeview/uudeview-0.5.20-r2.ebuild1
2 files changed, 37 insertions, 0 deletions
diff --git a/app-text/uudeview/files/uudeview-0.5.20-fix-append_signature.patch b/app-text/uudeview/files/uudeview-0.5.20-fix-append_signature.patch
new file mode 100644
index 000000000000..3dfecc18cb91
--- /dev/null
+++ b/app-text/uudeview/files/uudeview-0.5.20-fix-append_signature.patch
@@ -0,0 +1,36 @@
+From 3bd5dee4226142df3645b8a027ef9142277257cf Mon Sep 17 00:00:00 2001
+From: tastytea <tastytea@tastytea.de>
+Date: Sat, 1 May 2021 17:51:47 +0200
+Subject: [PATCH] Make append_signature() void.
+
+If the type specifier is missing, it defaults to int. From the looks of
+it, the function is meant to be void.
+---
+ inews/inews.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/inews/inews.c b/inews/inews.c
+index 5fa309d..d1c1ee8 100644
+--- a/inews/inews.c
++++ b/inews/inews.c
+@@ -143,7 +143,7 @@ char *argv[];
+ fprintf(ser_wr_fp, "%s\r\n", s);
+ }
+
+- append_signature();
++ void append_signature();
+
+ fprintf(ser_wr_fp, ".\r\n");
+ (void) fflush(ser_wr_fp);
+@@ -181,7 +181,7 @@ char *argv[];
+ * The rn-style DOTDIR environmental variable is used if present.
+ */
+
+-append_signature()
++void append_signature()
+ {
+ char line[256], sigfile[256];
+ char *cp;
+--
+2.26.3
+
diff --git a/app-text/uudeview/uudeview-0.5.20-r2.ebuild b/app-text/uudeview/uudeview-0.5.20-r2.ebuild
index c92ff28eafbc..72fc9d499c88 100644
--- a/app-text/uudeview/uudeview-0.5.20-r2.ebuild
+++ b/app-text/uudeview/uudeview-0.5.20-r2.ebuild
@@ -20,6 +20,7 @@ PATCHES=(
"${FILESDIR}"/${P}-man.patch
"${FILESDIR}"/${P}-rename.patch
"${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-fix-append_signature.patch
)
DOCS=( HISTORY INSTALL README )