summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-06-29 00:58:07 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-29 00:58:18 +0200
commit24d5a90e18b43177b7a423caac93f6a25e62993f (patch)
tree1b15fc555e921230a3baea959a24f783c2126318 /app-text/vgrep
parentdev-python/humanize: bump to 2.4.1 (diff)
downloadgentoo-24d5a90e18b43177b7a423caac93f6a25e62993f.tar.gz
gentoo-24d5a90e18b43177b7a423caac93f6a25e62993f.tar.bz2
gentoo-24d5a90e18b43177b7a423caac93f6a25e62993f.zip
app-text/vgrep: new package
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-text/vgrep')
-rw-r--r--app-text/vgrep/Manifest1
-rw-r--r--app-text/vgrep/metadata.xml12
-rw-r--r--app-text/vgrep/vgrep-2.3.1.ebuild33
3 files changed, 46 insertions, 0 deletions
diff --git a/app-text/vgrep/Manifest b/app-text/vgrep/Manifest
new file mode 100644
index 000000000000..6de74d934067
--- /dev/null
+++ b/app-text/vgrep/Manifest
@@ -0,0 +1 @@
+DIST vgrep-2.3.1.tar.gz 1149421 BLAKE2B c4c9a414bba5e509d57faa9ca6f6ce5cae1dbb001ff8b410ad54691ec6bf39f41c535fd25bdd5d93fdf89b4e4b49acf4dfa9a8956653e5c5e2ce39bd7da8d484 SHA512 0fa65151ae40f7fefc4e5b1af8e6ea332b50b1136849ec0902dd110786ca14204441e27c65a036b08fa56bf04a6325d8aa8ef2d4d02cdb0e0fe219896e24d694
diff --git a/app-text/vgrep/metadata.xml b/app-text/vgrep/metadata.xml
new file mode 100644
index 000000000000..4965843d0e80
--- /dev/null
+++ b/app-text/vgrep/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/vrothberg/vgrep/issues</bugs-to>
+ <remote-id type="github">vrothberg/vgrep</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/vgrep/vgrep-2.3.1.ebuild b/app-text/vgrep/vgrep-2.3.1.ebuild
new file mode 100644
index 000000000000..0ccd06c8eb51
--- /dev/null
+++ b/app-text/vgrep/vgrep-2.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit go-module
+
+DESCRIPTION="A pager for grep, git-grep and similar grep implementations"
+HOMEPAGE="https://github.com/vrothberg/vgrep"
+SRC_URI="https://github.com/vrothberg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ MIT MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Uses golangci-lint
+RESTRICT="test"
+
+DOCS=( README.md )
+
+# go binary
+QA_PRESTRIPPED="usr/bin/vgrep"
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ local prefix="${D}/usr"
+ mkdir -p "${prefix}"/bin || die
+
+ emake PREFIX="${prefix}" install
+}