summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/webgen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/webgen')
-rw-r--r--app-text/webgen/Manifest1
-rw-r--r--app-text/webgen/metadata.xml11
-rw-r--r--app-text/webgen/webgen-1.3.0.ebuild39
3 files changed, 51 insertions, 0 deletions
diff --git a/app-text/webgen/Manifest b/app-text/webgen/Manifest
new file mode 100644
index 000000000000..04ad790cea12
--- /dev/null
+++ b/app-text/webgen/Manifest
@@ -0,0 +1 @@
+DIST webgen-1.3.0.gem 198656 SHA256 0e50e515d1cd0f07b8d1bb72735b7a8fa162906d36541f9bcf10c41d2b1695a6 SHA512 921ffe9788ccf719eab7e8225b328990762ff04e928fbc699d4ab40170b437b54fe526887fd0de7209c6b7c2f50e0791ffe88eaebd73f77ef5a3df4c2235ba11 WHIRLPOOL be0bc1d3d1189847548b4aae83811d5f429badb724d21f5880c67d06d4ca21b7ca668c02f3b879344a123e5f2ed9f0cd949ab4c2c99002e0444360c09ddecb9b
diff --git a/app-text/webgen/metadata.xml b/app-text/webgen/metadata.xml
new file mode 100644
index 000000000000..afcfd85ce233
--- /dev/null
+++ b/app-text/webgen/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <herd>ruby</herd>
+ <use>
+ <flag name="builder">Enable programmatic HTML/XML generation</flag>
+ <flag name="highlight">Enable syntax highlighting for certain plugins</flag>
+ <flag name="markdown">Markdown support</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-text/webgen/webgen-1.3.0.ebuild b/app-text/webgen/webgen-1.3.0.ebuild
new file mode 100644
index 000000000000..32408b27e5a5
--- /dev/null
+++ b/app-text/webgen/webgen-1.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_DOCDIR="htmldoc/rdoc"
+RUBY_FAKEGEM_EXTRADOC="AUTHORS THANKS"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A template-based static website generator"
+HOMEPAGE="http://webgen.gettalong.org"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="builder highlight markdown"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( dev-ruby/kramdown
+ dev-ruby/minitest:5
+ dev-ruby/rdiscount
+ >=dev-ruby/sass-3.2:0 )"
+
+ruby_add_rdepend ">=dev-ruby/cmdparse-2.0.0:0
+ dev-ruby/systemu
+ dev-ruby/kramdown
+ builder? ( >=dev-ruby/builder-2.1.0 )
+ highlight? ( >=dev-ruby/coderay-0.8.312 )
+ markdown? ( dev-ruby/maruku )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/man1/webgen.1
+}