summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-05 17:06:53 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-05 17:28:56 +0100
commit7e8a13e89a33cbc49102ae9d828aceea58efc8db (patch)
treea5e19236f04ce7e5b78ef764e5b11c941e3ef932 /app-text/wscr/wscr-1.2-r2.ebuild
parentsys-apps/pcsc-lite: multiple fixes (diff)
downloadgentoo-7e8a13e89a33cbc49102ae9d828aceea58efc8db.tar.gz
gentoo-7e8a13e89a33cbc49102ae9d828aceea58efc8db.tar.bz2
gentoo-7e8a13e89a33cbc49102ae9d828aceea58efc8db.zip
app-text/wscr: EAPI=7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-text/wscr/wscr-1.2-r2.ebuild')
-rw-r--r--app-text/wscr/wscr-1.2-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-text/wscr/wscr-1.2-r2.ebuild b/app-text/wscr/wscr-1.2-r2.ebuild
new file mode 100644
index 000000000000..3a34f41b57d3
--- /dev/null
+++ b/app-text/wscr/wscr-1.2-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A Lightweight and Fast Anagram Solver"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="https://dev.gentoo.org/~jer/${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+RDEPEND="sys-apps/miscfiles"
+
+src_prepare() {
+ default
+ sed -i 's#"/usr/dict/words";#"/usr/share/dict/words";#' wscr.h || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" FLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin wscr
+ doman wscr.6
+ dodoc README
+}