summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-04-26 17:36:35 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-04-26 20:28:36 -0400
commit25d415e44016215cbdee3ef90a46d019925981ff (patch)
tree885f17e71e12e1c0adf1eaf8949a4e6fa3391a01 /app-text/xapian-omega/xapian-omega-1.4.4.ebuild
parentdev-libs/xapian: version bump to 1.4.4 (diff)
downloadgentoo-25d415e44016215cbdee3ef90a46d019925981ff.tar.gz
gentoo-25d415e44016215cbdee3ef90a46d019925981ff.tar.bz2
gentoo-25d415e44016215cbdee3ef90a46d019925981ff.zip
app-text/xapian-omega: version bump to 1.4.4
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text/xapian-omega/xapian-omega-1.4.4.ebuild')
-rw-r--r--app-text/xapian-omega/xapian-omega-1.4.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/xapian-omega/xapian-omega-1.4.4.ebuild b/app-text/xapian-omega/xapian-omega-1.4.4.ebuild
new file mode 100644
index 000000000000..d49ca33f6fdf
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.4.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+SRC_URI="http://www.oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
+HOMEPAGE="http://www.xapian.org/"
+S="${WORKDIR}/xapian-omega-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/xapian:0/30
+ dev-lang/perl
+ dev-libs/libpcre
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ # Protect /etc/omega.conf
+ echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega
+ doenvd "${T}"/20xapian-omega
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ # Directory containing Xapian databases:
+ keepdir /var/lib/omega/data
+
+ # Directory containing OmegaScript templates:
+ keepdir /var/lib/omega/templates
+ mv "${S}"/templates/* "${D}"/var/lib/omega/templates || die
+
+ # Directory to write Omega logs to:
+ keepdir /var/log/omega
+
+ # Directory containing any cdb files for the $lookup OmegaScript command:
+ keepdir /var/lib/omega/cdb
+}