summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-11-25 15:48:15 +0100
committerJeroen Roovers <jer@gentoo.org>2019-11-25 16:09:34 +0100
commita1f4538b709f5a898c8624593deff182300452fc (patch)
tree227157c3a365f214de092c01a808487d7f99c9b6 /app-text/xchm/xchm-1.31.ebuild
parentsys-kernel/vanilla-sources: Linux patch 5.4.0 (diff)
downloadgentoo-a1f4538b709f5a898c8624593deff182300452fc.tar.gz
gentoo-a1f4538b709f5a898c8624593deff182300452fc.tar.bz2
gentoo-a1f4538b709f5a898c8624593deff182300452fc.zip
app-text/xchm: Version 1.31
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-text/xchm/xchm-1.31.ebuild')
-rw-r--r--app-text/xchm/xchm-1.31.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-text/xchm/xchm-1.31.ebuild b/app-text/xchm/xchm-1.31.ebuild
new file mode 100644
index 000000000000..07a7c38f9ed6
--- /dev/null
+++ b/app-text/xchm/xchm-1.31.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+WX_GTK_VER="3.0-gtk3"
+inherit desktop wxwidgets xdg-utils
+
+DESCRIPTION="Utility for viewing Compiled HTML Help (CHM) files"
+HOMEPAGE="https://github.com/rzvncj/xCHM/"
+SRC_URI="https://github.com/rzvncj/xCHM/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="
+ >=dev-libs/chmlib-0.36
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ nls? ( virtual/libintl )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS README ChangeLog
+
+ domenu "${FILESDIR}"/xchm.desktop
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/xchm.xml
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}