summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/xdvik/xdvik-22.85-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/xdvik/xdvik-22.85-r1.ebuild')
-rw-r--r--app-text/xdvik/xdvik-22.85-r1.ebuild104
1 files changed, 104 insertions, 0 deletions
diff --git a/app-text/xdvik/xdvik-22.85-r1.ebuild b/app-text/xdvik/xdvik-22.85-r1.ebuild
new file mode 100644
index 000000000000..2c6864d17064
--- /dev/null
+++ b/app-text/xdvik/xdvik-22.85-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils flag-o-matic elisp-common toolchain-funcs multilib
+
+DESCRIPTION="DVI previewer for X Window System"
+HOMEPAGE="http://xdvi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xdvi/${P}.tar.gz"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="motif neXt Xaw3d emacs"
+
+RDEPEND=">=media-libs/t1lib-5.0.2
+ x11-libs/libXmu
+ x11-libs/libXp
+ x11-libs/libXpm
+ motif? ( >=x11-libs/motif-2.3:0 )
+ !motif? (
+ neXt? ( x11-libs/neXtaw )
+ !neXt? (
+ Xaw3d? ( x11-libs/libXaw3d )
+ !Xaw3d? ( x11-libs/libXaw )
+ )
+ )
+ dev-libs/kpathsea"
+DEPEND="sys-devel/flex
+ virtual/yacc
+ ${RDEPEND}"
+RDEPEND="${RDEPEND}
+ virtual/latex-base
+ !<app-text/texlive-2007"
+TEXMF_PATH=/usr/share/texmf
+S=${WORKDIR}/${P}/texk/xdvik
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-mksedscript.patch" \
+ "${FILESDIR}/${P}-mksedscript_gentoo.patch"
+ # Make sure system kpathsea headers are used
+ cd "${WORKDIR}/${P}/texk/kpathsea"
+ for i in *.h ; do echo "#include_next \"$i\"" > $i; done
+}
+
+src_configure() {
+ local toolkit
+
+ if use motif ; then
+ toolkit="motif"
+ use neXt && ewarn "neXt USE flag ignored (superseded by motif)"
+ use Xaw3d && ewarn "Xaw3d USE flag ignored (superseded by motif)"
+ elif use neXt ; then
+ toolkit="neXtaw"
+ use Xaw3d && ewarn "Xaw3d USE flag ignored (superseded by neXt)"
+ elif use Xaw3d ; then
+ toolkit="xaw3d"
+ else
+ toolkit="xaw"
+ fi
+
+ econf \
+ --with-system-t1lib \
+ --with-system-kpathsea \
+ --with-kpathsea-include="${EPREFIX}"/usr/include/kpathsea \
+ --with-xdvi-x-toolkit="${toolkit}" \
+ --x-includes="${EPREFIX}"/usr/include \
+ --x-libraries="${EPREFIX}"/usr/$(get_libdir)
+}
+
+src_compile() {
+ emake kpathsea_dir="${EPREFIX}/usr/include/kpathsea" texmf="${EPREFIX}${TEXMF_PATH}"
+ use emacs && elisp-compile xdvi-search.el
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodir /etc/texmf/xdvi /usr/share/X11/app-defaults
+ mv "${ED}${TEXMF_PATH}/xdvi/XDvi" "${ED}usr/share/X11/app-defaults" || die "failed to move config file"
+ dosym {/usr/share/X11/app-defaults,"${TEXMF_PATH}/xdvi"}/XDvi
+ for i in $(find "${ED}${TEXMF_PATH}/xdvi" -maxdepth 1 -type f) ; do
+ mv ${i} "${ED}etc/texmf/xdvi" || die "failed to move $i"
+ dosym {/etc/texmf,"${TEXMF_PATH}"}/xdvi/$(basename ${i})
+ done
+
+ dodoc BUGS FAQ README.*
+
+ use emacs && elisp-install tex-utils *.el *.elc
+
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry xdvi "XDVI" xdvik "Graphics;Viewer"
+ echo "MimeType=application/x-dvi;" >> "${ED}"usr/share/applications/xdvi-"${PN}".desktop
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elog "Add"
+ elog " (add-to-list 'load-path \"${EPREFIX}${SITELISP}/tex-utils\")"
+ elog " (require 'xdvi-search)"
+ elog "to your ~/.emacs file"
+ fi
+}