summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 10:02:56 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:24 +0100
commit8b2790f9d652e83146fccbf52c284b7e5cd3fc8f (patch)
tree811cde3044d599fa37f18e78625c233aeeb211be /app-text/xlhtml
parentapp-text/teseq: update EAPI 5 -> 7 (diff)
downloadgentoo-8b2790f9d652e83146fccbf52c284b7e5cd3fc8f.tar.gz
gentoo-8b2790f9d652e83146fccbf52c284b7e5cd3fc8f.tar.bz2
gentoo-8b2790f9d652e83146fccbf52c284b7e5cd3fc8f.zip
app-text/xlhtml: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/xlhtml')
-rw-r--r--app-text/xlhtml/xlhtml-0.5.1_p6.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/app-text/xlhtml/xlhtml-0.5.1_p6.ebuild b/app-text/xlhtml/xlhtml-0.5.1_p6.ebuild
index 8322bc031d19..ddc365d4a844 100644
--- a/app-text/xlhtml/xlhtml-0.5.1_p6.ebuild
+++ b/app-text/xlhtml/xlhtml-0.5.1_p6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools epatch vcs-clean
+inherit autotools vcs-clean
MY_PV=${PV/_p*/}
DEB_PR=${PV/*_p/}
@@ -13,17 +13,20 @@ HOMEPAGE="http://chicago.sourceforge.net/xlhtml/ http://packages.debian.org/etch
SRC_URI="
mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}.orig.tar.gz
mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}-${DEB_PR}.diff.gz"
+S="${WORKDIR}"/${PN}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-S=${WORKDIR}/${PN}
+PATCHES=(
+ "${WORKDIR}"/${PN}_${MY_PV}-${DEB_PR}.diff
+)
src_prepare() {
+ default
+
ecvs_clean
- epatch "${WORKDIR}"/${PN}_${MY_PV}-${DEB_PR}.diff
mv configure.{in,ac} || die