summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 17:48:16 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:59 +0100
commit42aa838aaa61a817051810e9c8dd6f7dd82bf25d (patch)
tree4d643b30acf0582ae2dbe5b050647f04be249e62 /app-text/xmlto
parentmedia-gfx/fondu: port to EAPI 7 (diff)
downloadgentoo-42aa838aaa61a817051810e9c8dd6f7dd82bf25d.tar.gz
gentoo-42aa838aaa61a817051810e9c8dd6f7dd82bf25d.tar.bz2
gentoo-42aa838aaa61a817051810e9c8dd6f7dd82bf25d.zip
app-text/xmlto: port old to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/xmlto')
-rw-r--r--app-text/xmlto/xmlto-0.0.28-r3.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/app-text/xmlto/xmlto-0.0.28-r3.ebuild b/app-text/xmlto/xmlto-0.0.28-r3.ebuild
index 75fca16f2d61..6b8268c5f689 100644
--- a/app-text/xmlto/xmlto-0.0.28-r3.ebuild
+++ b/app-text/xmlto/xmlto-0.0.28-r3.ebuild
@@ -1,9 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit epatch
+EAPI=7
DESCRIPTION="script for converting XML and DocBook documents to a variety of output formats"
HOMEPAGE="https://pagure.io/xmlto"
@@ -29,8 +27,12 @@ DEPEND="${RDEPEND}"
DOCS="AUTHORS ChangeLog FAQ NEWS README THANKS"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.0.22-format_fo_passivetex_check.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.0.22-format_fo_passivetex_check.patch
+ default
# fix symbol clash on Solaris
if [[ ${CHOST} == *-solaris* ]] ; then
@@ -42,5 +44,6 @@ src_configure() {
# We don't want the script to detect /bin/sh if it is bash.
export ac_cv_path_BASH=${BASH}
has_version sys-apps/util-linux || export GETOPT=getopt-long
+
econf
}