summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <dilfridge@gentoo.org>2018-05-28 15:27:44 +0200
committerAndreas K. Huettel <dilfridge@gentoo.org>2018-05-28 15:27:44 +0200
commit8165348a970678b204980b701381f2cc367de0ed (patch)
treeafdccbcfc9f76222e546b9881c79d5b172b12c54 /app-text/xournal
parentmedia-libs/opencv: add missing cpu_flags_x86_ssse3 (diff)
downloadgentoo-8165348a970678b204980b701381f2cc367de0ed.tar.gz
gentoo-8165348a970678b204980b701381f2cc367de0ed.tar.bz2
gentoo-8165348a970678b204980b701381f2cc367de0ed.zip
app-text/xournal: Version and EAPI bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-text/xournal')
-rw-r--r--app-text/xournal/Manifest1
-rw-r--r--app-text/xournal/xournal-0.4.8.2016.ebuild59
-rw-r--r--app-text/xournal/xournal-9999.ebuild15
3 files changed, 70 insertions, 5 deletions
diff --git a/app-text/xournal/Manifest b/app-text/xournal/Manifest
index 2ba2d9e35e90..7614a521a7a8 100644
--- a/app-text/xournal/Manifest
+++ b/app-text/xournal/Manifest
@@ -1 +1,2 @@
+DIST xournal-0.4.8.2016.tar.gz 646082 BLAKE2B 4f64fb45759616d99f961b8db575bec1620e089d9f87d4e02d3de7b1cb1d9189d439d78e5b89c93d5635138206f603e40bb33a46458d34a9ec050869e54be531 SHA512 1426d5c9ba3486fbe342d49fc19fcc162965cd6a7b7754f79665e43fe0e60e6f42f61969405ace78fdaa7b99cbb3d4b07b7fb5df246d68a329b52084b6eec76e
DIST xournal-0.4.8.tar.gz 641240 BLAKE2B cbf82f3ddb27854ce4a17fe80d1ed012f47529ee3f41eac0118f4948f4ca76488fb647c77ab21c99cf19de0016df4db31a448d4c626a42219b2b13b297b5d51e SHA512 cfd5760a0e832ef02786a29cb744d4932aeee97c4d6992b430e647bd59aaef1042735203824d0eaf9da9b884dcdadcfb8f5acea221638db91438ae46a6ee42bf
diff --git a/app-text/xournal/xournal-0.4.8.2016.ebuild b/app-text/xournal/xournal-0.4.8.2016.ebuild
new file mode 100644
index 000000000000..50477f8a4537
--- /dev/null
+++ b/app-text/xournal/xournal-0.4.8.2016.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+[[ ${PV} == *9999 ]] && GNOME2_EAUTORECONF=yes
+
+inherit gnome2
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.code.sf.net/p/xournal/code"
+ unset SRC_URI
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="An application for notetaking, sketching, and keeping a journal using a stylus"
+HOMEPAGE="http://xournal.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+pdf vanilla"
+
+COMMONDEPEND="
+ app-text/poppler[cairo]
+ dev-libs/atk
+ dev-libs/glib
+ gnome-base/libgnomecanvas
+ media-libs/freetype
+ media-libs/fontconfig
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango
+"
+RDEPEND="${COMMONDEPEND}
+ pdf? ( app-text/poppler[utils] app-text/ghostscript-gpl )
+"
+DEPEND="${COMMONDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default_src_prepare
+ if ! use vanilla; then
+ eapply "${FILESDIR}"/xournal-0.4.8-aspectratio.patch
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" desktop-install
+
+ dodoc ChangeLog AUTHORS README
+ dodoc -r html-doc/*
+}
diff --git a/app-text/xournal/xournal-9999.ebuild b/app-text/xournal/xournal-9999.ebuild
index 422842c0e82f..50477f8a4537 100644
--- a/app-text/xournal/xournal-9999.ebuild
+++ b/app-text/xournal/xournal-9999.ebuild
@@ -1,9 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-GCONF_DEBUG=no
+EAPI=6
[[ ${PV} == *9999 ]] && GNOME2_EAUTORECONF=yes
@@ -23,7 +21,7 @@ HOMEPAGE="http://xournal.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+pdf"
+IUSE="+pdf vanilla"
COMMONDEPEND="
app-text/poppler[cairo]
@@ -45,10 +43,17 @@ DEPEND="${COMMONDEPEND}
virtual/pkgconfig
"
+src_prepare() {
+ default_src_prepare
+ if ! use vanilla; then
+ eapply "${FILESDIR}"/xournal-0.4.8-aspectratio.patch
+ fi
+}
+
src_install() {
emake DESTDIR="${D}" install
emake DESTDIR="${D}" desktop-install
dodoc ChangeLog AUTHORS README
- dohtml -r html-doc/*
+ dodoc -r html-doc/*
}