summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNickolas Raymond Kaczynski <nrk@disroot.org>2023-02-23 18:46:00 +0600
committerJoonas Niilola <juippis@gentoo.org>2023-02-28 15:56:08 +0200
commit181f5f3f12ebdfeed6a016fec1b6de7a52dd46dc (patch)
treebc777c779da60fec1e70ead112572a87c387ae3a /app-text/zathura-cb/zathura-cb-0.1.10.ebuild
parentnet-vpn/i2pd: add 2.46.1 (diff)
downloadgentoo-181f5f3f12ebdfeed6a016fec1b6de7a52dd46dc.tar.gz
gentoo-181f5f3f12ebdfeed6a016fec1b6de7a52dd46dc.tar.bz2
gentoo-181f5f3f12ebdfeed6a016fec1b6de7a52dd46dc.zip
app-text/zathura-cb: bump to v0.1.10
Signed-off-by: Nickolas Raymond Kaczynski <nrk@disroot.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text/zathura-cb/zathura-cb-0.1.10.ebuild')
-rw-r--r--app-text/zathura-cb/zathura-cb-0.1.10.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/zathura-cb/zathura-cb-0.1.10.ebuild b/app-text/zathura-cb/zathura-cb-0.1.10.ebuild
new file mode 100644
index 000000000000..3686e39e9456
--- /dev/null
+++ b/app-text/zathura-cb/zathura-cb-0.1.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg-utils optfeature
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-cb.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+ SRC_URI="https://pwmt.org/projects/zathura-cb/download/${P}.tar.xz"
+fi
+
+DESCRIPTION="Comic book plug-in for zathura with 7zip, rar, tar and zip support"
+HOMEPAGE="https://pwmt.org/projects/zathura-cb/"
+
+LICENSE="ZLIB"
+SLOT="0"
+
+DEPEND="app-arch/libarchive:=
+ >=app-text/zathura-0.3.9
+ dev-libs/girara
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ optfeature "jpeg support" x11-libs/gdk-pixbuf[jpeg]
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}