summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-02-06 00:24:52 +0100
committerMichael Weber <xmw@gentoo.org>2017-02-06 00:25:59 +0100
commit43a44244b3c67991e21323d2428a198fdda95be4 (patch)
tree769d281f103c43862dead1b6a0612f625bcb7b58 /app-text/zathura-cb/zathura-cb-0.1.6.ebuild
parentdev-util/huc: EAPI 6 bump. (diff)
downloadgentoo-43a44244b3c67991e21323d2428a198fdda95be4.tar.gz
gentoo-43a44244b3c67991e21323d2428a198fdda95be4.tar.bz2
gentoo-43a44244b3c67991e21323d2428a198fdda95be4.zip
app-text/zathura-cb: Remove optional decompressors from RDEPEND (bug 608284).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text/zathura-cb/zathura-cb-0.1.6.ebuild')
-rw-r--r--app-text/zathura-cb/zathura-cb-0.1.6.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/app-text/zathura-cb/zathura-cb-0.1.6.ebuild b/app-text/zathura-cb/zathura-cb-0.1.6.ebuild
index fe196068973e..08888166b2fc 100644
--- a/app-text/zathura-cb/zathura-cb-0.1.6.ebuild
+++ b/app-text/zathura-cb/zathura-cb-0.1.6.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs readme.gentoo-r1
[[ ${PV} == 9999* ]] && inherit git-2
DESCRIPTION="Comic book plug-in for zathura with 7zip, rar, tar and zip support"
@@ -24,17 +24,12 @@ KEYWORDS=""
fi
IUSE=""
-COMMON_DEPEND=">=app-text/zathura-0.3.1
+RDEPEND=">=app-text/zathura-0.3.1
dev-libs/glib:2=
app-arch/libarchive:=
x11-libs/cairo:=
x11-libs/gdk-pixbuf:="
-RDEPEND="${COMMON_DEPEND}
- app-arch/p7zip
- app-arch/tar
- app-arch/unrar
- app-arch/unzip"
-DEPEND="${COMMON_DEPEND}
+DEPEND="${RDEPEND}
virtual/pkgconfig"
pkg_setup() {
@@ -53,4 +48,13 @@ src_compile() {
src_install() {
emake "${myzathuraconf[@]}" install
dodoc AUTHORS
+ readme.gentoo_create_doc
}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
+
+FORCE_PRINT_ELOG=1
+DOC_CONTENTS="Consider installing app-arch/p7zip app-arch/tar app-arch/unrar
+app-arch/unzip for additional file support."