summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-10-10 22:51:36 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-10-10 22:51:36 +0300
commitbfcc83a5a551175bf09465547ed6d326d62cdf17 (patch)
treeef1acae94012710af9bc1d1f80981d853603245d /app-text/zathura-djvu/zathura-djvu-0.2.8.ebuild
parentprofiles: last-riting dev-python/flask-restless (diff)
downloadgentoo-bfcc83a5a551175bf09465547ed6d326d62cdf17.tar.gz
gentoo-bfcc83a5a551175bf09465547ed6d326d62cdf17.tar.bz2
gentoo-bfcc83a5a551175bf09465547ed6d326d62cdf17.zip
app-text/zathura-djvu: Version bump (v0.2.8)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'app-text/zathura-djvu/zathura-djvu-0.2.8.ebuild')
-rw-r--r--app-text/zathura-djvu/zathura-djvu-0.2.8.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/zathura-djvu/zathura-djvu-0.2.8.ebuild b/app-text/zathura-djvu/zathura-djvu-0.2.8.ebuild
new file mode 100644
index 000000000000..71439fb37996
--- /dev/null
+++ b/app-text/zathura-djvu/zathura-djvu-0.2.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils meson xdg-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-djvu.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="https://pwmt.org/projects/zathura-djvu/download/${P}.tar.xz"
+fi
+
+DESCRIPTION="DjVu plug-in for zathura"
+HOMEPAGE="https://pwmt.org/projects/zathura-djvu/"
+
+LICENSE="ZLIB"
+SLOT="0"
+
+DEPEND="app-text/djvu
+ >=app-text/zathura-0.3.9
+ dev-libs/girara
+ dev-libs/glib:2
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}