summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-10-17 15:36:00 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-10-17 15:37:16 +0300
commit373dffd374368f1e169d012da0f1cb4000d705cf (patch)
treef25283c65675bbff30a97c7e982913e7634852fb /app-text/zathura-ps/zathura-ps-0.2.6.ebuild
parentxfce-extra/xfce4-diskperf-plugin: x86 stable (bug #668738) (diff)
downloadgentoo-373dffd374368f1e169d012da0f1cb4000d705cf.tar.gz
gentoo-373dffd374368f1e169d012da0f1cb4000d705cf.tar.bz2
gentoo-373dffd374368f1e169d012da0f1cb4000d705cf.zip
app-text/zathura-ps: Version bump (v0.2.6)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'app-text/zathura-ps/zathura-ps-0.2.6.ebuild')
-rw-r--r--app-text/zathura-ps/zathura-ps-0.2.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/zathura-ps/zathura-ps-0.2.6.ebuild b/app-text/zathura-ps/zathura-ps-0.2.6.ebuild
new file mode 100644
index 000000000000..9a5fded445c1
--- /dev/null
+++ b/app-text/zathura-ps/zathura-ps-0.2.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-ps.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="https://pwmt.org/projects/zathura/plugins/download/${P}.tar.xz"
+fi
+
+DESCRIPTION="PostScript plug-in for zathura"
+HOMEPAGE="https://pwmt.org/projects/zathura-ps/download/"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-text/libspectre
+ >=app-text/zathura-0.3.9
+ dev-libs/girara
+ dev-libs/glib:2
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"