summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-02-27 00:10:02 +0100
committerMichael Weber <xmw@gentoo.org>2016-02-27 00:24:50 +0100
commitb622949ff05f3853416c611dc2b10907155914ee (patch)
tree97f73ec2f5bd2ba8905eb540b35a91273ab417a9 /app-text/zathura/zathura-0.3.5.ebuild
parentmedia-gfx/graphite2: Fix tests, mostly... bug 575250 (diff)
downloadgentoo-b622949ff05f3853416c611dc2b10907155914ee.tar.gz
gentoo-b622949ff05f3853416c611dc2b10907155914ee.tar.bz2
gentoo-b622949ff05f3853416c611dc2b10907155914ee.zip
app-text/zathura: Version bump.
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-text/zathura/zathura-0.3.5.ebuild')
-rw-r--r--app-text/zathura/zathura-0.3.5.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/app-text/zathura/zathura-0.3.5.ebuild b/app-text/zathura/zathura-0.3.5.ebuild
new file mode 100644
index 000000000000..94e403b1a3ec
--- /dev/null
+++ b/app-text/zathura/zathura-0.3.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils fdo-mime multilib toolchain-funcs virtualx
+[[ ${PV} == 9999* ]] && inherit git-2
+
+DESCRIPTION="A highly customizable and functional document viewer"
+HOMEPAGE="http://pwmt.org/projects/zathura/"
+if ! [[ ${PV} == 9999* ]]; then
+SRC_URI="http://pwmt.org/projects/${PN}/download/${P}.tar.gz"
+fi
+EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
+EGIT_BRANCH="develop"
+
+LICENSE="ZLIB"
+SLOT="0"
+if ! [[ ${PV} == 9999* ]]; then
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+else
+KEYWORDS=""
+fi
+IUSE="+magic sqlite synctex test"
+
+RDEPEND=">=dev-libs/girara-0.2.5:3=
+ >=dev-libs/glib-2.32:2=
+ x11-libs/cairo:=
+ >=x11-libs/gtk+-3.6:3
+ magic? ( sys-apps/file:= )
+ sqlite? ( dev-db/sqlite:3= )
+ synctex? ( >=app-text/texlive-core-2015 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( dev-libs/check )"
+
+pkg_setup() {
+ myzathuraconf=(
+ WITH_MAGIC=$(usex magic 1 0)
+ WITH_SQLITE=$(usex sqlite 1 0)
+ WITH_SYNCTEX=$(usex synctex 1 0)
+ PREFIX="${EPREFIX}"/usr
+ LIBDIR='${PREFIX}'/$(get_libdir)
+ CC="$(tc-getCC)"
+ SFLAGS=''
+ VERBOSE=1
+ DESTDIR="${D}"
+ )
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_test() {
+ Xemake "${myzathuraconf[@]}" test
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" install
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}