summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-20 03:09:26 +0000
committerSam James <sam@gentoo.org>2022-01-20 03:09:26 +0000
commitb02e1593d0916e5657fb7e1d3bf34a90b8f34f03 (patch)
tree72227ec8f593fd25599774daed5066668dec42cb /app-text/zathura
parentsys-apps/accountsservice: fix build with meson 0.61 (diff)
downloadgentoo-b02e1593d0916e5657fb7e1d3bf34a90b8f34f03.tar.gz
gentoo-b02e1593d0916e5657fb7e1d3bf34a90b8f34f03.tar.bz2
gentoo-b02e1593d0916e5657fb7e1d3bf34a90b8f34f03.zip
app-text/zathura: fix build with meson 0.61
Closes: https://bugs.gentoo.org/831468 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/zathura')
-rw-r--r--app-text/zathura/files/zathura-0.4.8-meson-0.61-build.patch27
-rw-r--r--app-text/zathura/zathura-0.4.8.ebuild6
2 files changed, 32 insertions, 1 deletions
diff --git a/app-text/zathura/files/zathura-0.4.8-meson-0.61-build.patch b/app-text/zathura/files/zathura-0.4.8-meson-0.61-build.patch
new file mode 100644
index 000000000000..577eddc4da1f
--- /dev/null
+++ b/app-text/zathura/files/zathura-0.4.8-meson-0.61-build.patch
@@ -0,0 +1,27 @@
+https://github.com/pwmt/zathura/commit/c6ec5044c5ff843979050bfb81742d14740bb656.patch
+https://bugs.gentoo.org/831468
+
+From: Sebastian Ramacher <sebastian@ramacher.at>
+Date: Sat, 30 Oct 2021 15:41:25 +0200
+Subject: [PATCH] Fix build with meson 0.60
+
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -19,7 +19,7 @@ endif
+ i18n = import('i18n')
+ podir = join_paths(meson.project_source_root(), 'po')
+
+-desktop = i18n.merge_file('desktop',
++desktop = i18n.merge_file(
+ input: 'org.pwmt.zathura.desktop.in',
+ output: 'org.pwmt.zathura.desktop',
+ install: true,
+@@ -28,7 +28,7 @@ desktop = i18n.merge_file('desktop',
+ type: 'desktop'
+ )
+
+-appdata = i18n.merge_file('appdata',
++appdata = i18n.merge_file(
+ input: 'org.pwmt.zathura.appdata.xml.in',
+ output: 'org.pwmt.zathura.appdata.xml',
+ install: true,
diff --git a/app-text/zathura/zathura-0.4.8.ebuild b/app-text/zathura/zathura-0.4.8.ebuild
index 0de2aed7939f..83b02ddfd08f 100644
--- a/app-text/zathura/zathura-0.4.8.ebuild
+++ b/app-text/zathura/zathura-0.4.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -40,6 +40,10 @@ BDEPEND="doc? ( dev-python/sphinx )
dev-libs/check )
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${P}-meson-0.61-build.patch
+)
+
src_configure() {
local emesonargs=(
-Dconvert-icon=disabled