summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-22 16:47:12 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-22 16:47:12 +0200
commit076d6c09d5140787a40b01ca1f8a9712c82b9d23 (patch)
tree56221e03cfa4d89ae48c0f3a2effad0b6e6d79f8 /app-text
parentx11-terms/sakura: Keyword 3.8.4 riscv, #866027 (diff)
downloadgentoo-076d6c09d5140787a40b01ca1f8a9712c82b9d23.tar.gz
gentoo-076d6c09d5140787a40b01ca1f8a9712c82b9d23.tar.bz2
gentoo-076d6c09d5140787a40b01ca1f8a9712c82b9d23.zip
app-text/zotero-bin: add 6.0.13
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zotero-bin/Manifest2
-rw-r--r--app-text/zotero-bin/zotero-bin-6.0.13.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/app-text/zotero-bin/Manifest b/app-text/zotero-bin/Manifest
index b903b5a2984c..d382ffd6d98c 100644
--- a/app-text/zotero-bin/Manifest
+++ b/app-text/zotero-bin/Manifest
@@ -1,2 +1,4 @@
DIST zotero-bin-6.0.10.tar.bz2 68712203 BLAKE2B 45e4ff33de1cf84c9c6bf9177de4096eb52abfaeb3347153376598d1dd8ad0d90a11383a4a1c62f77e8234f167cf0950fbfa4f58b74d33f48ec073a22a8bc832 SHA512 06ac2a21f8ec7576c759b6375a66e7e9370ac81f6e8832b7ca4850311a2d7e208d17b5fe2cda372763f80756fbaccaffc75afc828014611723931ace2958f19a
+DIST zotero-bin-6.0.13-amd64.tar.bz2 68738437 BLAKE2B d70dd479b8f9517f7eb0017c9be891df39e74b919719f4308e6fb8cea064920f41717377ab8072af3ed2b60c28deeb75fba918e7a2b03f7d40eef08c15c38446 SHA512 150ad3f213ad7289e09f79422f4840a4a288d80bfe661a9c06d330198c52018efe01bc68629485fd822647902df59ec5862bee5df13d1de106a2ccd84b647944
+DIST zotero-bin-6.0.13-x86.tar.bz2 70376898 BLAKE2B dc16790081cdf9fbb35febd537b180192f43a28dabd8ee012ef721ebeabd516f422bd04e2bb8820571dabfd26a5039d72822e07b9df7f457be0834762ec75eb4 SHA512 4bf71e788cb97497e4acb18150dc7865fe4d2e90a2d658e660c54b2312ec3939365226f30bc65f736c0b38316a238b97ddde0555ccf12b95c449d396d7872c1d
DIST zotero-bin-6.0.9.tar.bz2 68609695 BLAKE2B a921b6558d53b162ef2d3ef23db73dfd20f9f87f2fa533b28d95fe33f5e20c1c9d341b72d7a51f4780f3081f6f925991b40193ae5287565f3de0a4d937ec9333 SHA512 4610d0e7ae8fe228ffe6ceff9cd9724bc47b8fa7b6b0d0cdac3e539b67af037aeaaeb5d7f0935306f2e6bb719ca16bcad266a576e6389674f6717b15d610643c
diff --git a/app-text/zotero-bin/zotero-bin-6.0.13.ebuild b/app-text/zotero-bin/zotero-bin-6.0.13.ebuild
new file mode 100644
index 000000000000..a31cabce92e9
--- /dev/null
+++ b/app-text/zotero-bin/zotero-bin-6.0.13.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Helps you collect, organize, cite, and share your research sources"
+HOMEPAGE="https://www.zotero.org"
+SRC_URI="
+ amd64? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-x86_64&version=${PV} -> ${P}-amd64.tar.bz2 )
+ x86? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-i686&version=${PV} -> ${P}-x86.tar.bz2 )
+"
+S="${WORKDIR}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/atk
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/zotero/*"
+
+src_prepare() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ # disable auto-update
+ sed -i -e 's/\(pref("app.update.enabled"\).*/\1, false);/' defaults/preferences/prefs.js || die
+
+ # disable default oo installation questions - manual installation is still possible
+ sed -i -e 's/\(pref("extensions.zoteroOpenOfficeIntegration.skipInstallation"\).*/\1, true);/' \
+ extensions/zoteroOpenOfficeIntegration@zotero.org/defaults/preferences/zoteroOpenOfficeIntegration.js || die
+
+ # fix desktop-file
+ sed -i -e 's#^Exec=.*#Exec=zotero#' zotero.desktop || die
+ sed -i -e 's#Icon=zotero.*#Icon=zotero#' zotero.desktop || die
+
+ default
+}
+
+src_install() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ dodir opt/zotero
+ cp -a * "${ED}/opt/zotero" || die
+
+ dosym ../../opt/zotero/zotero usr/bin/zotero
+
+ domenu zotero.desktop
+
+ for size in 16 32 48 256; do
+ newicon -s ${size} chrome/icons/default/default${size}.png zotero.png
+ done
+}