summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-14 08:23:29 +0000
committerSam James <sam@gentoo.org>2023-12-14 08:32:14 +0000
commit0ea33c8059755dde7d4b024759d528b591dbdba7 (patch)
treebe3e15d0b2402e2443b97bcc9e36725b774a4d5f /app-text
parentapp-text/lesspipe: drop 2.06, 2.07, 2.08 (diff)
downloadgentoo-0ea33c8059755dde7d4b024759d528b591dbdba7.tar.gz
gentoo-0ea33c8059755dde7d4b024759d528b591dbdba7.tar.bz2
gentoo-0ea33c8059755dde7d4b024759d528b591dbdba7.zip
app-text/lesspipe: add 2.11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/lesspipe/Manifest1
-rw-r--r--app-text/lesspipe/lesspipe-2.11.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/lesspipe/Manifest b/app-text/lesspipe/Manifest
index ec3ced3b2cb8..109aab1f1334 100644
--- a/app-text/lesspipe/Manifest
+++ b/app-text/lesspipe/Manifest
@@ -1 +1,2 @@
DIST lesspipe-2.10.tar.gz 170918 BLAKE2B 156fe53975252ac6c59a637ffe0ee9862be0699f325a0b328e5c0f2cb5e6f7d8324481f3d3211cbb15a585a5dabde45adf87ac4e0af91cd34540359331684264 SHA512 3fe122cf0adf8dd3e0782ae65132c58d76f7131a2e8c30d9a10eb426c6f63e50b4b5e02b6792524a37b27ca572bd3e2661a6c82118e9c4ed5ecbccaf2c5a42e2
+DIST lesspipe-2.11.tar.gz 171212 BLAKE2B aa7cf35f00d9db4ad7cb48ae89089a4d0c5d6c6e41ec902bc7ba6d4fd218f8ea90e1fdf3d6fcbac1dd1f86eb841a0daa6838b0086905fd4b0535d91040ef85aa SHA512 ed75d8529bd24876b11a50d0ada476299569d0fe716c390de84a0630ae475594f96370ffbed64fc5d9e2417dcbaa7b2f68630e32f665dff799667c2653b0265f
diff --git a/app-text/lesspipe/lesspipe-2.11.ebuild b/app-text/lesspipe/lesspipe-2.11.ebuild
new file mode 100644
index 000000000000..2cb52db742fa
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-2.11.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo bash-completion-r1
+
+DESCRIPTION="Preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://github.com/wofr06/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+# Please check again on bumps! (bug #734896)
+RESTRICT="!test? ( test ) test"
+
+RDEPEND="dev-lang/perl"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ test? ( app-editors/vim )
+"
+
+src_configure() {
+ # Not an autoconf script.
+ edo ./configure --prefix="${EPREFIX}"/usr
+}
+
+src_compile() {
+ # Nothing to build (avoids the "all" target)
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+
+ rm "${ED}"/usr/share/bash-completion/less_completion || die
+ newbashcomp less_completion less
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}