summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-12-05 08:41:35 +0100
committerHans de Graaff <graaff@gentoo.org>2021-12-05 08:41:35 +0100
commit1ef5e5ffa91374e5537b9ad3c39adb85976726a3 (patch)
treeefd98e1cf6b761e9981944118af3bfa73b62bc1d /app-text
parentdev-lang/ruby: cleanup (diff)
downloadgentoo-1ef5e5ffa91374e5537b9ad3c39adb85976726a3.tar.gz
gentoo-1ef5e5ffa91374e5537b9ad3c39adb85976726a3.tar.bz2
gentoo-1ef5e5ffa91374e5537b9ad3c39adb85976726a3.zip
app-text/ronn-ng: fix build dependencies
We need these dependencies also during build since we call rake and the Rakefile requires them. Closes: https://bugs.gentoo.org/828129 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild b/app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild
index 7353defff61e..421aa12c568d 100644
--- a/app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild
+++ b/app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild
@@ -20,12 +20,18 @@ IUSE=""
RDEPEND+="!app-text/ronn"
-ruby_add_rdepend "
+DEPS="
>=dev-ruby/kramdown-2.1:2
- =dev-ruby/mustache-1*
>=dev-ruby/nokogiri-1.9.0:0
"
+ruby_add_rdepend "
+ =dev-ruby/mustache-1*
+ ${DEPS}
+"
+
+ruby_add_bdepend "${DEPS}"
+
all_ruby_prepare() {
sed -i -e '/mustache/ s/0.7/1.0/' ${RUBY_FAKEGEM_GEMSPEC} || die
}