summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2019-05-12 16:20:21 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-05-12 17:02:42 -0400
commit2065e77265e59484059a96a93f9cfbcc7bc44a19 (patch)
tree2747b0972a05a31d67122c5e941fe0745db0c260 /app-text
parentmate-extra/mate-system-monitor: Bump to 1.22.1 (diff)
downloadgentoo-2065e77265e59484059a96a93f9cfbcc7bc44a19.tar.gz
gentoo-2065e77265e59484059a96a93f9cfbcc7bc44a19.tar.bz2
gentoo-2065e77265e59484059a96a93f9cfbcc7bc44a19.zip
app-text/atril: bump to 1.22.1 and add missing dep
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/atril/Manifest1
-rw-r--r--app-text/atril/atril-1.22.1.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-text/atril/Manifest b/app-text/atril/Manifest
index 2c0f93cb1e0e..899347d40b99 100644
--- a/app-text/atril/Manifest
+++ b/app-text/atril/Manifest
@@ -1 +1,2 @@
DIST atril-1.22.0.tar.xz 1819580 BLAKE2B 6d5ae9e42407c5c7ae716c0650eda2085bc2206f442dbbb04dbf549263cdabe6d28761deb14bb9557534f26828882cf5b9373698b5e2c29f4b70445ebfabaa5b SHA512 bf940178647c348fd78e828bcb3a55c4ff6195d4020bf198ae5ba4a96e2fe582f7e30fb9d4cde4143e82ae783358373d3a9fd68413295586da9fe1b374e2f034
+DIST atril-1.22.1.tar.xz 1766980 BLAKE2B 0b7b1a7dfff13c5d803fed4140596940b20a322fce54c9f0faecd8e80bdc1e5e498603851a10a88763b20444377bcf4e7b124ac08953ab6aa4b3b2cce021a46c SHA512 838ae397c868ac417c9266e4a06525d66214650cf8647e91c1472d83d50c8954f6dbb29411384892a98f0929e1fbac9947118bd0db10d50400fc0d5270a3619d
diff --git a/app-text/atril/atril-1.22.1.ebuild b/app-text/atril/atril-1.22.1.ebuild
new file mode 100644
index 000000000000..7fa4d3d8236f
--- /dev/null
+++ b/app-text/atril/atril-1.22.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Atril document viewer for MATE"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="caja dbus debug djvu dvi epub +introspection gnome-keyring +postscript t1lib tiff xps"
+
+REQUIRED_USE="t1lib? ( dvi )"
+
+RDEPEND="
+ >=app-text/poppler-0.22[cairo]
+ dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libxml2-2.5:2
+ sys-libs/zlib
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libICE
+ >=x11-libs/libSM-1:0
+ x11-libs/libX11
+ >=x11-libs/cairo-1.9.10
+ x11-libs/pango
+ caja? ( >=mate-base/caja-1.17.1[introspection?] )
+ djvu? ( >=app-text/djvu-3.5.17:0 )
+ dvi? (
+ virtual/tex-base
+ t1lib? ( >=media-libs/t1lib-5:5 )
+ )
+ epub? (
+ dev-libs/mathjax
+ >=net-libs/webkit-gtk-2.4.3:4
+ )
+ gnome-keyring? ( >=app-crypt/libsecret-0.5 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6:= )
+ postscript? ( >=app-text/libspectre-0.2 )
+ tiff? ( >=media-libs/tiff-3.6:0 )
+ xps? ( >=app-text/libgxps-0.2.1 )
+ !!app-text/mate-document-viewer"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/rarian
+ app-text/yelp-tools
+ >=app-text/scrollkeeper-dtd-1:1.0
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+# Tests use dogtail which is not available on Gentoo.
+RESTRICT="test"
+
+src_configure() {
+ # Passing --disable-help would drop offline help, that would be inconsistent
+ # with helps of the most of GNOME apps that doesn't require network for that.
+ mate_src_configure \
+ --disable-tests \
+ --enable-comics \
+ --enable-pdf \
+ --enable-pixbuf \
+ --enable-previewer \
+ --enable-thumbnailer \
+ $(use_with gnome-keyring keyring) \
+ $(use_enable caja) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable djvu) \
+ $(use_enable dvi) \
+ $(use_enable epub) \
+ $(use_enable introspection) \
+ $(use_enable postscript ps) \
+ $(use_enable t1lib) \
+ $(use_enable tiff) \
+ $(use_enable xps)
+}