summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-09 03:31:15 +0000
committerSam James <sam@gentoo.org>2021-05-09 03:54:01 +0000
commit3012979ebea857a513d50993bf7853cddd06e628 (patch)
tree52ee674fbc2ccbbf23b67c4443e6981db0f08033 /app-text
parentsys-fs/squashfs-tools-ng: Version bump to 1.1.1 (diff)
downloadgentoo-3012979ebea857a513d50993bf7853cddd06e628.tar.gz
gentoo-3012979ebea857a513d50993bf7853cddd06e628.tar.bz2
gentoo-3012979ebea857a513d50993bf7853cddd06e628.zip
app-text/qpdf: add 10.3.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/qpdf/Manifest1
-rw-r--r--app-text/qpdf/qpdf-10.3.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-text/qpdf/Manifest b/app-text/qpdf/Manifest
index d8bdda0c9fdc..b021b7c1b9cd 100644
--- a/app-text/qpdf/Manifest
+++ b/app-text/qpdf/Manifest
@@ -1,3 +1,4 @@
DIST qpdf-10.0.4.tar.gz 18465085 BLAKE2B 3b9edc38069d58d43d26b131da755b7921b7add905ed652e3abb48d9b2e140d0c3b38f0250dbd3dca1c4b3dadf76c636606c6fa802b1ebe2dda77444badd828e SHA512 0a8c243928a3273d78b4a898e17a619f1565ec5e9b6f637800a2937749fb8006d0438fee2e623d2f8dc715bfb478ee818e86e9da7c7e0fcf14af496464b79a07
DIST qpdf-10.1.0.tar.gz 18528427 BLAKE2B e62b1c8ca8d301b082cde292cb8430d6ae26433c77a30a6a21379f00cbfb3df09117d042f532f77d372d091a89a3f6581ef7d7734c67a4a1b29c1708129078f3 SHA512 f9b22d89fc62e430e6232c840ad74d220ac9eb09d7f2dfe2c42c1c943d35b5fd25e2abec9970ac19ad7ad25dc3d95c74e68e50bad395abf815cf71c432233106
DIST qpdf-10.3.1.tar.gz 18956768 BLAKE2B 1581799b7bd08e28829fd26571ddaa06fc8460fd4f6935a4f69374e49c445cfcbe824175de7137817a26278c2f58d7524f6440181945064fc853f4dd30b2d528 SHA512 def94fe09770e67fe13bd3fc946667fc2935e7c448eb43602e15218e5b50f452e4f4152411f818115620e67934890c37203663537ac77ed1fcd4317e01a6d623
+DIST qpdf-10.3.2.tar.gz 18943834 BLAKE2B 5b4e320ddd663721d8201139842bb09a752347f86c3e33116063b2fff1426aed5ff6e3c581c120771a712a8ed278102e0d41816db207a25dabd84e5b89490d35 SHA512 4e630959abf27d1801e36d0cbd754945ded42ade9299057a6b9a642c7cb2a3f8242e274642f1c33a65b4a5a77562d91dcbe64fd5772d483cbe5edb4a6a389219
diff --git a/app-text/qpdf/qpdf-10.3.2.ebuild b/app-text/qpdf/qpdf-10.3.2.ebuild
new file mode 100644
index 000000000000..42acbd1e5cbf
--- /dev/null
+++ b/app-text/qpdf/qpdf-10.3.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 Artistic-2 )"
+# subslot = libqpdf soname version
+SLOT="0/28"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris"
+IUSE="doc examples ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ net-libs/gnutls:0=
+ sys-libs/zlib
+ virtual/jpeg:0=
+ ssl? (
+ dev-libs/openssl:0=
+ )
+"
+DEPEND="${RDEPEND}
+ test? (
+ app-text/ghostscript-gpl[tiff(+)]
+ media-libs/tiff
+ sys-apps/diffutils
+ )
+"
+
+DOCS=( ChangeLog README.md TODO )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-implicit-crypto
+ --enable-crypto-gnutls
+ --enable-crypto-native
+ --with-default-crypto=gnutls
+ --disable-static
+ $(use_enable ssl crypto-openssl)
+ $(use_enable test test-compare-images)
+ )
+ CONFIG_SHELL="${BROOT}/bin/bash" econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ dobin examples/build/.libs/*
+ fi
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}