summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-12-29 13:17:08 +0800
committerIan Delaney <idella4@gentoo.org>2015-12-29 13:58:02 +0800
commit36a3a663067b95fea9e0b965ebe53ec3cce5b19e (patch)
treee5a1d171f6121da495577bd0cdf75e4ea1c95a26 /app-text
parentsys-apps/findutils: version bump to 4.6.0 (diff)
downloadgentoo-36a3a663067b95fea9e0b965ebe53ec3cce5b19e.tar.gz
gentoo-36a3a663067b95fea9e0b965ebe53ec3cce5b19e.tar.bz2
gentoo-36a3a663067b95fea9e0b965ebe53ec3cce5b19e.zip
app-text/referencer: revbumps to vns. 1.2.0-r1, 1.2.1-r1
conversion -> python-single-r1 eclass, reduced DESCRIPTION to 80 chars, slot operator set to dep /gtkmm, cxxflags set to std=gnu++11 @ configure, patches submitted by proxy maintainer via the gentoo bug, reviewed and runtested Gentoo bug: #520798 Package-Manager: portage-2.2.24
Diffstat (limited to 'app-text')
-rw-r--r--app-text/referencer/referencer-1.2.0-r1.ebuild50
-rw-r--r--app-text/referencer/referencer-1.2.1-r1.ebuild49
2 files changed, 99 insertions, 0 deletions
diff --git a/app-text/referencer/referencer-1.2.0-r1.ebuild b/app-text/referencer/referencer-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..82b752ee3935
--- /dev/null
+++ b/app-text/referencer/referencer-1.2.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit fdo-mime eutils python-single-r1 flag-o-matic
+
+DESCRIPTION="Application to organise documents or references, and to generate BibTeX files"
+HOMEPAGE="https://launchpad.net/referencer"
+SRC_URI="https://launchpad.net/${PN}/1./${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-text/poppler-0.12.3-r3
+ >=dev-cpp/gtkmm-2.8:*
+ >=dev-cpp/libglademm-2.6.0
+ >=dev-cpp/gconfmm-2.14.0
+ >=dev-cpp/gtkmm-utils-0.4.1
+ >=dev-libs/boost-1.52.0-r4"
+
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.3.2
+ virtual/pkgconfig
+ >=dev-lang/perl-5.8.1
+ dev-perl/libxml-perl
+ dev-util/intltool
+ app-text/rarian"
+
+src_prepare () {
+ epatch "${FILESDIR}/${PN}-desktop-file-validate.patch"
+ python_fix_shebang plugins
+}
+
+src_configure() {
+ append-cxxflags -std=gnu++11
+ econf --disable-update-mime-database --enable-python
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}
diff --git a/app-text/referencer/referencer-1.2.1-r1.ebuild b/app-text/referencer/referencer-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..0160a753c2d6
--- /dev/null
+++ b/app-text/referencer/referencer-1.2.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit fdo-mime eutils python-single-r1 flag-o-matic
+
+DESCRIPTION="Application to organise documents or references, and to generate BibTeX files"
+HOMEPAGE="https://launchpad.net/referencer"
+SRC_URI="https://launchpad.net/${PN}/1./${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-text/poppler-0.12.3-r3:=[cairo]
+ >=dev-cpp/gtkmm-2.8:*
+ >=dev-cpp/libglademm-2.6.0
+ >=dev-cpp/gconfmm-2.14.0
+ >=dev-libs/boost-1.52.0-r4"
+
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.3.2
+ virtual/pkgconfig
+ >=dev-lang/perl-5.8.1
+ dev-perl/libxml-perl
+ dev-util/intltool
+ app-text/rarian"
+
+src_prepare () {
+ python_fix_shebang plugins
+}
+
+src_configure() {
+ append-cxxflags -std=gnu++11
+ econf --disable-update-mime-database --enable-python
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}