summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-02-11 18:38:25 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-02-11 18:38:25 +0700
commit37f5c08489eaffe7a29ed75435eedda849bb16f4 (patch)
treeef289ca6f5c2879d4f16d24ceaa0552ed82e9fdc /app-text
parentapp-text/crengine-ng: bump to 0.9.7 (diff)
downloadgentoo-37f5c08489eaffe7a29ed75435eedda849bb16f4.tar.gz
gentoo-37f5c08489eaffe7a29ed75435eedda849bb16f4.tar.bz2
gentoo-37f5c08489eaffe7a29ed75435eedda849bb16f4.zip
app-text/crqt-ng: bump to 1.0.9
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/crqt-ng/Manifest1
-rw-r--r--app-text/crqt-ng/crqt-ng-1.0.9.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-text/crqt-ng/Manifest b/app-text/crqt-ng/Manifest
index 8b8465d541d6..883b8479c04b 100644
--- a/app-text/crqt-ng/Manifest
+++ b/app-text/crqt-ng/Manifest
@@ -1 +1,2 @@
DIST crqt-ng-1.0.4.tar.bz2 424685 BLAKE2B d661b0ea7e8eee2c386b07fe38e106af800ca2308a8a8e63e4f98d6c446362cf7d653fc5e1f3eb58ebd22e71dd42252f3db057129751d0eb5a3c7e08258eb8cb SHA512 411e28d343153467cbf0d57f28d80c3983f3dae67332b3cf19e5c26304b81e010b4dee02462a58a57c7c70253794a73ac42801d9527bf92e947a14e678075f6d
+DIST crqt-ng-1.0.9.tar.bz2 435826 BLAKE2B 771b073fadf6f1bc9ddf7887603aaf6081d54c2effd548523f7afbb8b6bdf20d21bf55c1c37101662c2b851e932c6b4dce777c8e9160b059dbb1daed499db1c4 SHA512 b4f395be1d2029024dfb064f38db2ea372587151de1f5fae3cef492d4285d6ce597bc93a48d98594c5b703db8c99ba29cd9afdaae4c39b80b53cf6a7bafdbb97
diff --git a/app-text/crqt-ng/crqt-ng-1.0.9.ebuild b/app-text/crqt-ng/crqt-ng-1.0.9.ebuild
new file mode 100644
index 000000000000..9db0e77feeaf
--- /dev/null
+++ b/app-text/crqt-ng/crqt-ng-1.0.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PLOCALES="bg cs hu ru uk"
+inherit cmake plocale xdg
+
+DESCRIPTION="Cross-platform e-book reader"
+HOMEPAGE="https://gitlab.com/coolreader-ng/crqt-ng"
+SRC_URI="https://gitlab.com/coolreader-ng/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gif +svg +chm +harfbuzz +libunibreak +fribidi +zstd +libutf8proc"
+
+CDEPEND=">=app-text/crengine-ng-0.9.7[png,jpeg,fontconfig,gif=,svg=,chm=,harfbuzz=,fribidi=,zstd=,libutf8proc=]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${CDEPEND}"
+BDEPEND="${CDEPEND}
+ dev-qt/linguist-tools:5"
+
+src_prepare() {
+ cmake_src_prepare
+ xdg_environment_reset
+
+ # locales
+ plocale_find_changes "${S}"/src/i18n 'crqt_' '.ts'
+ sed -e "s|set(LANGUAGES .*)|set(LANGUAGES $(plocale_get_locales))|i" \
+ -i "${S}"/src/CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+}
+
+src_configure() {
+ CMAKE_USE_DIR="${S}"
+ CMAKE_BUILD_TYPE="Release"
+ local mycmakeargs=(-DUSE_QT=QT5)
+ cmake_src_configure
+}