summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-17 23:17:29 +0100
committerSam James <sam@gentoo.org>2022-10-17 23:19:06 +0100
commit3a1b720795beee61d4e093a5479664ea59faf933 (patch)
tree64e6f85b2562f3857af271520b2804a08f663615 /app-text
parentlinux-mod.eclass: pass -q to xz (diff)
downloadgentoo-3a1b720795beee61d4e093a5479664ea59faf933.tar.gz
gentoo-3a1b720795beee61d4e093a5479664ea59faf933.tar.bz2
gentoo-3a1b720795beee61d4e093a5479664ea59faf933.zip
app-text/podofo: fix automagic dep on libunistring
Hard-disable it and prefer libidn for unicode support. Closes: https://bugs.gentoo.org/877443 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/podofo/podofo-0.9.6_p20190928-r101.ebuild (renamed from app-text/podofo/podofo-0.9.6_p20190928-r100.ebuild)9
-rw-r--r--app-text/podofo/podofo-0.9.7-r1.ebuild (renamed from app-text/podofo/podofo-0.9.7.ebuild)12
2 files changed, 12 insertions, 9 deletions
diff --git a/app-text/podofo/podofo-0.9.6_p20190928-r100.ebuild b/app-text/podofo/podofo-0.9.6_p20190928-r101.ebuild
index bd8bf05d1b85..b38d2983b91f 100644
--- a/app-text/podofo/podofo-0.9.6_p20190928-r100.ebuild
+++ b/app-text/podofo/podofo-0.9.6_p20190928-r101.ebuild
@@ -21,12 +21,13 @@ REQUIRED_USE="${LUA_REQUIRED_USE}
RDEPEND="${LUA_DEPS}
idn? ( net-dns/libidn:= )
- dev-libs/openssl:0=
+ dev-libs/openssl:=
+ dev-libs/libunistring:=
media-libs/fontconfig:=
media-libs/freetype:2=
- virtual/jpeg:0=
- media-libs/libpng:0=
- media-libs/tiff:0=
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/tiff:=
sys-libs/zlib:="
DEPEND="${RDEPEND}
test? ( dev-util/cppunit )"
diff --git a/app-text/podofo/podofo-0.9.7.ebuild b/app-text/podofo/podofo-0.9.7-r1.ebuild
index 97e2a987c7a1..e15f6767e6c5 100644
--- a/app-text/podofo/podofo-0.9.7.ebuild
+++ b/app-text/podofo/podofo-0.9.7-r1.ebuild
@@ -21,12 +21,12 @@ REQUIRED_USE="${LUA_REQUIRED_USE}
RDEPEND="${LUA_DEPS}
idn? ( net-dns/libidn:= )
- dev-libs/openssl:0=
+ dev-libs/openssl:=
media-libs/fontconfig:=
media-libs/freetype:2=
- virtual/jpeg:0=
- media-libs/libpng:0=
- media-libs/tiff:0=
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/tiff:=
sys-libs/zlib:="
DEPEND="${RDEPEND}
test? ( dev-util/cppunit )
@@ -100,9 +100,11 @@ src_configure() {
-DLUA_VERSION="$(lua_get_version)"
-DWANT_BOOST=$(usex boost ON OFF)
-DHAVE_LIBIDN=$(usex idn ON OFF)
+ # We use libidn for unicode support instead
+ -DCMAKE_DISABLE_FIND_PACKAGE_UNISTRING=ON
-DPODOFO_HAVE_CPPUNIT=$(usex test ON OFF)
-DPODOFO_BUILD_LIB_ONLY=$(usex tools OFF ON)
- )
+ )
cmake_src_configure
mkdir -p "${S}/test/TokenizerTest/objects" || die