summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-06-21 18:29:31 +0200
committerDavid Seifert <soap@gentoo.org>2022-06-21 18:29:31 +0200
commit4014b64bd87c37ba9f80422bf8eac36cd8af9642 (patch)
tree5b2cb11b9c9b79da71f2dda8bfa09bc730da98e9 /app-text
parentapp-text/psutils: update EAPI 6 -> 8 (diff)
downloadgentoo-4014b64bd87c37ba9f80422bf8eac36cd8af9642.tar.gz
gentoo-4014b64bd87c37ba9f80422bf8eac36cd8af9642.tar.bz2
gentoo-4014b64bd87c37ba9f80422bf8eac36cd8af9642.zip
app-text/wv: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/wv/wv-1.2.9-r3.ebuild (renamed from app-text/wv/wv-1.2.9-r2.ebuild)39
1 files changed, 18 insertions, 21 deletions
diff --git a/app-text/wv/wv-1.2.9-r2.ebuild b/app-text/wv/wv-1.2.9-r3.ebuild
index a587d0bffd5f..4876a095e7fd 100644
--- a/app-text/wv/wv-1.2.9-r2.ebuild
+++ b/app-text/wv/wv-1.2.9-r3.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit autotools
DESCRIPTION="Tool for conversion of MSWord doc and rtf files to something readable"
-SRC_URI="http://abiword.org/downloads/${PN}/${PV}/${P}.tar.gz"
HOMEPAGE="http://wvware.sourceforge.net/"
+SRC_URI="http://abiword.org/downloads/${PN}/${PV}/${P}.tar.gz"
-IUSE="tools wmf"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+IUSE="tools wmf"
RDEPEND="
>=dev-libs/glib-2:2
@@ -19,15 +20,15 @@ RDEPEND="
sys-libs/zlib
media-libs/libpng:0=
dev-libs/libxml2:2
- tools? ( app-text/texlive-core
- dev-texlive/texlive-latex )
- wmf? ( >=media-libs/libwmf-0.2.2 )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
+ tools? (
+ app-text/texlive-core
+ dev-texlive/texlive-latex
+ )
+ wmf? ( >=media-libs/libwmf-0.2.2 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}/${P}-format-security.patch" )
+PATCHES=( "${FILESDIR}"/${P}-format-security.patch )
src_prepare() {
default
@@ -46,17 +47,13 @@ src_prepare() {
}
src_configure() {
- econf \
- --disable-static \
- $(use_with wmf libwmf)
+ econf $(use_with wmf libwmf)
}
src_install() {
default
find "${ED}" -name '*.la' -delete || die
- rm -f "${ED}"/usr/share/man/man1/wvConvert.1
- if use tools; then
- dosym /usr/share/man/man1/wvWare.1 /usr/share/man/man1/wvConvert.1
- fi
+ rm -f "${ED}"/usr/share/man/man1/wvConvert.1 || die
+ use tools && dosym wvWare.1 /usr/share/man/man1/wvConvert.1
}