summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThamognya Kodi <contact@thamognya.com>2022-06-13 21:42:21 +0700
committerFlorian Schmaus <flow@gentoo.org>2022-06-21 09:00:43 +0200
commit526c2c69df0f08ea44120c940729a1f90149502c (patch)
tree2ae52f34da0245e9272a32480135e25a4f544f53 /app-text
parentmedia-sound/beets: sync live (diff)
downloadgentoo-526c2c69df0f08ea44120c940729a1f90149502c.tar.gz
gentoo-526c2c69df0f08ea44120c940729a1f90149502c.tar.bz2
gentoo-526c2c69df0f08ea44120c940729a1f90149502c.zip
app-text/asciidoc: bump to 10.20, take maintainership
Signed-off-by: Thamognya Kodi <contact@thamognya.com> Closes: https://github.com/gentoo/gentoo/pull/25876 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/asciidoc/Manifest1
-rw-r--r--app-text/asciidoc/asciidoc-10.2.0.ebuild48
-rw-r--r--app-text/asciidoc/metadata.xml19
3 files changed, 62 insertions, 6 deletions
diff --git a/app-text/asciidoc/Manifest b/app-text/asciidoc/Manifest
index b612e2b0e863..67d8e93f4689 100644
--- a/app-text/asciidoc/Manifest
+++ b/app-text/asciidoc/Manifest
@@ -1,3 +1,4 @@
DIST asciidoc-10.1.4.tar.gz 215656 BLAKE2B 461dd31ebc7067430e595935681ec6e0207a481ec183f0c29e08be444b40a26afabe84ac46dd8f7c563eb8d28ad8eed4b63a23fccd1105d817f7402f6afbfc5e SHA512 fba8c8efe215da0170fc46f1245af831c7b9e982705fbd9cbfe4cd2b979286b49f30570b116bc9f095f060099904a30671ab0498a58fc24b0069575ecf026a7d
+DIST asciidoc-10.2.0.tar.gz 216824 BLAKE2B 500038d655f820fe89048bbff683ae029c7044de839ae4f9ec4666b843585511c99bbc1991ec1764262f33c55b08845661fc1e62eb21bb3250d3168e369928ff SHA512 2f83c7f6d1d0a34948035347833ca59841de1271e8d008b4c4a43a7a8273b230148e6f51ee8f6e2dc702460e27c495037fbe2d6d43195b70bf3447ad86390d28
DIST asciidoc-9.1.0.new.tar.gz 1249958 BLAKE2B 0a98f58f7604f84d704092313c38563634bad5d697d60d02760f3be1d2a78a97ee2488dda3a9918b02e0062710175c6513d600f3fbd850fe700bf3fa917a3980 SHA512 c30854a936228fe5bcf2f9305741fbc4b17ef088b2fa637d5f3b19c7803306085634fb71146f0b089c2fad01f986da71a4fae364139f520c0906525317c0c4a6
DIST asciidoc-9.1.1.new.tar.gz 1259206 BLAKE2B da274d3a9389ee2e42ad1be70467f11d0164df3e6f9102e6ef1be6a802dbeb12898786fa1fe37a95755d0db8c9df5d5dd3faf000dfb73b701a83af3cc0261606 SHA512 74b83e8c8904fd761783c2f572d353656fc0794c6cb427f61e9179c9f80b6fc3b3ee8d028baba4e25eafe5f8cf5318f9984a5828849a793a7520f83e6fe50d66
diff --git a/app-text/asciidoc/asciidoc-10.2.0.ebuild b/app-text/asciidoc/asciidoc-10.2.0.ebuild
new file mode 100644
index 000000000000..9f376b493bd3
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-10.2.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1 optfeature readme.gentoo-r1
+
+DESCRIPTION="A plain text human readable/writable document format"
+HOMEPAGE="https://asciidoc.org/ https://github.com/asciidoc-py/asciidoc-py/"
+# Could use the github tarball but we need autotools then
+#SRC_URI="https://github.com/asciidoc-py/asciidoc-py/releases/download/${PV}/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75
+ dev-libs/libxslt
+ dev-libs/libxml2:2"
+
+DOC_CONTENTS="
+If you are going to use a2x, please also look at a2x(1) under
+REQUISITES for a list of runtime dependencies.
+"
+
+src_install() {
+ distutils-r1_src_install
+
+ # TODO: Consider using Debian patch to allow /usr/share?
+ insinto /usr/share/asciidoc
+ doins -r asciidoc/resources/.
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "music filter support" "media-sound/lilypond virtual/imagemagick-tools"
+ optfeature "source filter support" "dev-util/source-highlight dev-python/pygments app-text/highlight"
+ optfeature "latex filter support" "dev-texlive/texlive-latex app-text/dvipng" "dev-texlive/texlive-latex app-text/dvisvgm"
+ optfeature "graphviz filter support" "media-gfx/graphviz"
+}
diff --git a/app-text/asciidoc/metadata.xml b/app-text/asciidoc/metadata.xml
index 3c2c02f59a4b..47206531efeb 100644
--- a/app-text/asciidoc/metadata.xml
+++ b/app-text/asciidoc/metadata.xml
@@ -1,10 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="sourceforge">asciidoc</remote-id>
- <remote-id type="github">asciidoc-py/asciidoc-py</remote-id>
- <bugs-to>https://github.com/asciidoc-py/asciidoc-py/issues</bugs-to>
- </upstream>
+ <maintainer type="person" proxied="yes">
+ <name>Thamognya Kodi</name>
+ <email>contact@thamognya.com</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">asciidoc</remote-id>
+ <remote-id type="github">asciidoc-py/asciidoc-py</remote-id>
+ <bugs-to>https://github.com/asciidoc-py/asciidoc-py/issues</bugs-to>
+ </upstream>
</pkgmetadata>